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Part 1 – Overview of Topic
The Chesapeake Bay is the largest estuary in the United States—some 200 miles long—
draining 64,000 square miles in six states. The bay supports more than 3600 species of plants,
fish and animals. Water quality of the Chesapeake Bay is threatened by a number of
anthropogenic activities which have increased the amount and velocity of runoff. These activities
have led to sedimentation rates estimated to be four to five times greater than in the 1800’s in
some areas of the bay. Sedimentation is a major threat to the health of the Chesapeake Bay, as it
can bury benthic animals. Sedimentation also clouds water, preventing light from reaching
submerged aquatic vegetation, thus inhibiting photosynthesis. Reducing photosynthesis limits
oxygen concentration in the bay, producing “dead zones” where aquatic organisms cannot live
during prolonged periods during the summer months. Sediments also transport toxic materials
and excess nutrients, causing further problems in the bay.
Remote sensing provides a powerful way to visualize changes in land use; it is also an
excellent tool for recognizing sedimentation of major rivers and water bodies. Assessing remote
sensing imagery for changes in land use (i.e., increasing urbanization/impervious surface area)
and combining this with the a GIS watershed model provides a powerful set of conceptual and
practical tools to better understand the science and engineering behind the contemporary major
policy debate over urban sprawl and watershed protection. Overlaying watershed imagery with a
GIS watershed/basin model is a powerful way to conceptualize sediment transport in the
watershed. The project provides hands-on experience integrating a variety of resources to better
understand the science behind this timely major policy issue in the mid-Atlantic region. This
project also provides practical experience in planning, managing, and completing a mediumsized, data-intensive environmental assessment project. This learning unit is intended for
students with basic knowledge of remote sensing, and familiarity with ENVI software.
Intermediate to advanced skills in ArcGIS are also required.
The unit is intended to be completed in small groups of three to four students. The small
group setting provides an opportunity for peer teaching and learning, which is important given the
complex skills and abstract thinking required in the project. The learning unit can be completed
in approximately 12 to 16 hours.

Part 2 – Preprocessing LandSat Satellite Imagery
You will compare two satellite images of the same area, looking for changes in
land use between two LandSat images. The first image is from May 1987, and was

1

acquired by the LandSat 5 satellite. The second image is from October 2001, and was
acquired by the LandSat 7 satellite.
These two images, acquired 14 years apart should make changes in land use—
such as an increase in urbanization—apparent. These two images should also illustrate
differences in imagery caused by seasonality, as the LandSat 5 image from May should
have different vegetative patterns than the LandSat 7 image from October.
1.0 Download the LandSat image files.
The LandSat 5 image can be found on the UMCP Global Land Cover Facility (GLCF).
The LandSat 7 image can be found on USGS GLOVIS.
Some things to note:
a) Both images are georeferenced
b) Characteristics of the respective sensor packages:
LandSat 5 (Thematic Mapper (TM) Sensor):
Seven spectral bands, including a thermal band:
o Band 1 Visible (0.45 – 0.52 µm) 30 m
o Band 2 Visible (0.52 – 0.60 µm) 30 m
o Band 3 Visible (0.63 – 0.69 µm) 30 m
o Band 4 Near-Infrared (0.76 – 0.90 µm) 30 m
o Band 5 Shortwave-Infrared (1.55 – 1.75 µm) 30 m
o Band 6 Thermal (10.40 – 12.50 µm) 120 m
o Band 7 Shortwave-Infrared (2.08 – 2.35 µm) 30 m
Ground Sampling Interval (pixel size): 30 m reflective
LandSat 7 (Enhanced Thematic Mapper Plus (ETM+) Sensor):
Eight spectral bands, including a pan and thermal band:
o Band 1 Visible (0.45 – 0.52 µm) 30 m
o Band 2 Visible (0.52 – 0.60 µm) 30 m
o Band 3 Visible (0.63 – 0.69 µm) 30 m
o Band 4 Near-Infrared (0.77 – 0.90 µm) 30 m
o Band 5 Shortwave-Infrared (1.55 – 1.75 µm) 30 m
o Band 6 Thermal (10.40 – 12.50 µm) 60 m Low Gain / High Gain
o Band 7 Shortwave-Infrared (2.08 – 2.35 µm) 30 m
o Band 8 Panchromatic (PAN) (0.52 - 0.90 µm) 15 m
Ground Sampling Interval (pixel size): 30 m reflective
On-board calibration was added to LandSat 7
c) The bottom line is that we have different sensors packages on each LandSat satellite so
there are differences due to bandpass. However, these differences are probably smaller
than the atmospheric differences. So, we will classify each image separately, and then
compare the two classified images to assess the change.
2.0 Decompress LandSat files
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3.0 Preprocess LandSat Files
3.1 Open ENVI, and set the ENVI processing environment (save time and clicks!):
File > Preferences > Default Directories tab
At a minimum, set the Data Directory, Temp Directory, and Output Directory (see below
for an example):

Note: When you are done setting your preferences, you can save them as a file. This
way you can re-load your preferences (reload the file) next time you work on your
project, and save time in future…
4.0 Convert to Reflectance
For more details, see ENVI Help topic: Preprocessing Utilities [User] > LandSat TM
Calibration
4.1 First, rename each spectral band to the standard format.
The naming convention for LandSat 7 is as follows:
L7fppprrr_rrrYYYYMMDD_AAA.XXX
Where:
L7 = LandSat 7
f = ETM+ data format (ignored)
ppp = Starting path of the product
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rrr_rrr = Starting and ending rows of the product (the ending row is ignored)
YYYYMMDD = Acquisition date of the image
AAA = Band number:
B10 = Band 1
B20 = Band 2
B30 = Band 3
B40 = Band 4
B50 = Band 5
B61 = Band 6L (low gain)
B62 = Band 6H (high gain)
B70 = Band 7
B80 = Band 8
XXX = File type (ignored)
Rename all seven bands from the LandSat 7 image (downloaded from GLOVIS). For
example, rename p015r033_7t20011005_z18_nn70.tif to
L7f015033_00020011005_B70.tif following this convention.
4.2 Calibrate to reflectance (using the Web) (See ENVI Help > Preprocessing Utilities
for more details.)
4.2.1 From the ENVI Main Menu go to Basic Tools > Preprocessing > Calibration
Utilities > LandSat TM. This opens the TM Calibration Input File dialog box.

4.2.2 Click the Open button. Select New File, and navigate to your re-named files.
Select (highlight) a single file to load.
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4.2.3 Click Open to load the file. The TM Calibration Input File dialog box now lists
your file under Select Input File. You can see metadata associated with your file under
the File Information portion of the dialog box.
4.2.4 Be sure the Fill Scene button is selected. Click OK.
4.2.5 The TM Calibration Parameters dialog box now opens.

Notice that the date is entered in the dialog box—this should match the date of
collection for this image band. Note the values for Sun Elevation and Scale—they
are all incorrect! We will get the proper values from the Internet.
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4.2.6 Select the radio button for Reflectance.
4.2.7 Now click the Get Calibration Parameters from Web.

Notice that the values for Sun Elevation, Data Acquisition Band, and Scale have all
been updated. Also check the Data Acquisition Month, Day, and Year—these should
have been updated to match these values for your file.
4.2.8 Click Output Result to File
4.2.9 Click Enter Output Filename Choose.
4.2.10 Browse to the directory where you want to save your file. Name and save this
file (something like L7f015033_00020011005_B10_refl).
4.2.11 Click OK. ENVI completes the processing and adds your corrected to
reflectance file to the Available Bands List window.
4.2.12 Complete the analogous steps for the remainder of your LandSat 7 bands.
4.3 If you are using LandSat 5 data, the calibration process differs somewhat from
that when working with LandSat 7 TM data.
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4.3.1 First, notice that the LandSat 5 file naming convention differs slightly from
LandSat 7 naming convention (4.1 above): L5f015033_00019870516_B10
4.3.2. Note the “L5” designation for LandSat 5. Rename your files following the
convention above.
4.4 Calibrate to reflectance (without Web input). As of this lesson, calibration files
were not available from the Web, for downloading into ENVI to process LandSat 5
images.
4.4.1 As a result, you will need to get the sun elevation from the associated file
metadata, as this will have to be entered manually into the calibration dialog box in
ENVI. (For the image you are using, the value is 59.06 degrees. You can find this in
the metadata (text file) associated with the LandSat 5 data you downloaded.)
4.4.2 You will also have to manually enter LMIN and LMAX for each band. These
values (from USGS) are provided for you below:

Band 1
Band 2
Band 3
Band 4
Band 5
Band 7

LMIN
-1.52
-2.84
-1.17
-1.51
-0.37
-0.15

LMAX
152.1
296.81
204.3
206.2
27.19
14.38

4.4.3 From the ENVI Main Menu go to Basic Tools > Preprocessing > Calibration
Utilities > Landsat TM
The initial TM Calibration dialog box opens.
4.4.4 Set LandSat Satellite radio button to “5”
4.4.5 You will have to enter all the parameters manually. A completed dialog box for
Band 1 follows:
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Notes: Satellite = LandSat 5
Acquisition Day, Month and Year entered manually (from metadata)
Sun elevation from metadata
Data Acquisition Band from file
Scale from table above (Be sure to match the correct Data Acquisition Band and
Scale values!)
4.4.6 Click Output Result to File.
4.4.7 Click Output Filename “Choose”.
4.4.8 Browse to the directory where you want to save your file. Name the file
appropriately. (Something like L5f015033_00020011005_B10_refl).
4.4.9 Click OK. ENVI completes the processing and adds the corrected to reflectance
file to the Available Bands List window.
4.4.10 Complete the analogous steps for the remainder of the LandSat 5 bands.
4.5 Create a Data Cube (“Layer Stacking”) and Rename Data Cube Bands
4.5.1. From the ENVI Main Menu go to Basic Tools > Layer Stacking
4.5.1.1 In the Layer Stacking Parameters dialog window, click “Import File…”
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4.5.1.2 In the Layer Stacking Input File window, under Select Input File, select the
corrected reflective bands 1-5, and band 7.
4.5.1.3 Set up the Layer Stacking Parameters as below. Be sure to set the projection
parameters (WGS-84 UTM18N for this area of Virginia/Maryland) and be sure the pixel
size is the same for each of your images.)

4.5.1.4 In the Layer Stacking Parameter Window, click Reorder Files.
4.5.1.5 In the Reorder Files Window, drag band 1 to position 1 (topmost position),
followed by the other bands (i.e., position the bands in ascending order). (In the example
below, band1 and band 2 have been moved to their correct positions. You can see that
band 3 still needs to be dragged up into the third position).
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4.5.1.6 When you have all bands in the correct position, Click OK.
4.5.1.7 Choose a file name. (NOTE: be sure to add “.img” as the extension to your file
name. This will help you know that your data cube has been saved as an ENVI image
file, and it will make loading your data much faster in future. For example,
…L5f015033_00019870516_ref.img).
4.5.1.8. Browse and save to your directory. Your new data cube will now load in your
Available Bands List (see below).

4.5.2 Rename Data Cube Bands. Note that the bands are grouped under
L5f015033_00019870516_refl.img. The current individual band names are awkward.
4.5.2.1 From the ENVI Main Menu, select File > Edit ENVI Header
4.5.2.2 From the Edit Header Input File window, select your data stack (the file with the
“.img” extension!) and click OK.
4.5.2.3 In the Header Info window, select Edit Attributes > Band Names
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4.5.2.4 In the Edit Band Name values window, click on each band and rename with its
respective LandSat band name and number. For example, rename “Layer (TM Cal (Band
1:L5f015033_00019870516_B10.tif):L5f015033_00019870516_B10_refl) as “Band 1 –
Blue”.
(Recall that for LandSat images:
Band 1 = Blue
Band 2 = Green
Band 3 = Red
Band 4 = NIR
Band 5 = SWIR
Band 7 = SWIR2)
(TIP: Select each band name and change it BEFORE you click OK—that way you can
change all the names at one time!)
4.5.2.5 Select OK. An example of a renamed data cube is below:
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4.5.3 Complete the analogous process for the LandSat 7 data, building an image file for
the corrected to reflectance bands, with appropriate band names.
5.0 Image-to-Image Registration
The files used to build the LandSat 5 image data stack and the Landsat 7 image data stack
were geotiffs—the data have already been referenced to the surface of the earth.
However, we do need to register the LandSat 5 image to the LandSat 7 image, so that we
get a pixel-to-pixel match between the two images. We will register to the LandSat 7
image, as imagery form this later satellite/sensor package has better geometric accuracy
than imagery from LandSat 5.
Rules of thumb regarding which LandSat image should be your base image:
(1) A terrain corrected L7 image
(2) A terrain corrected L5 (or L4) image
(3) A non-terrain corrected L7 image
(4) Note about GeoCover and GLS data sets
a. GeoCover images were registered to the terrain corrected circa 1990
data (these data will eventually be replaced by the GLS data)
b. Global Land Survey (GLS) data are registered to the terrain corrected
circa 2000 data (this will be very robust, sub pixel accuracy, ~ 15m)
(5) With all LandSat data now available at no charge, all LandSat images will
be registered and orthorectified using the GLS GCPs, so you will not
need to do an image-to-image registration when using those images.
5.1

Open ENVI

5.1.1

Load the LandSat 5 and LandSat 7 data stacks you created previously.

5.1.2 Load LandSat 7 as an RGB image into Display #1. Load LandSat 5 as an RGB
image into Display #2. (Put the image with the best known geolocation in Display #1.
This will become your base image.)
5.1.3

Make note of your base image’s dimensions

5.1.3.1 From the ENVI Main Menu Window, select File > Edit ENVI Header
5.1.3.2 In the Edit Header Input File, select your base image
5.1.3.3 Under “File Information:” make note of the Dimensions. They are in format:
samples x lines x bands (e.g. 8061 x 7081 x 6).
5.2 Image to Image Registration
5.2.1 In the ENVI Main Menu Window, select Map > Registration > Select GCPs:
Image to Image
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5.2.2 In the Image to Image Registration Window, select your better geolocated image for
your Base Image, and the other image for your Warp image, then click Okay.
5.2.3 In the Ground Control Points Selection, select “Show List”.
5.2.3.1 An Image to Image GCP List Window appears, this will show you the points you
pick and your RMS Error.
5.2.4 To start, locate an easily identifiable location on both images (e.g. one corner of a
road intersection, a runway, a bridge, etc. These are your Ground Control Points (GCPs).
5.2.5 In your zoom window, place the red “cross-hairs” at the same place on both images,
then double click “Add Point” in the Ground Control Points Selection.
5.2.6 After you add a point, in the Ground Control Points Selection Window, select File >
Save Table to ASCII; name your files, select Okay. Do this after every point addition.
5.2.6.1 Once you have 5 points, ENVI will populate the RMS box.
5.2.6.2 Your GCPs should be dispersed throughout your image. Delete (or “re-tie”) any
points with a very high RMS. In general, the more GCPs, the better! Note that RMS is
in pixels, or fractions of a pixel (not units of measure). Note also that you can zoom
extensively, letting you set GCPs to a particular location within a given pixel.
5.2.7 Once you are satisfied with your RMS values (in general, total RMS less than 0.33)
and you have well dispersed GCPs, in the Ground Control Points Selection window,
select Options > Warp File
5.2.7.1 Select your warp file data stack and click Okay.
5.2.7.2 In the Registration Parameters Window, Change Upper Left X to 1 and Upper
Left Y to 1, then enter the # of Samples and Lines from your BASE IMAGE (e.g., for my
example 8061x7081).
5.2.7.3 Unless you have reason to change values, leave the method as Polynomial,
Degree as 1, and the Resampling method as Nearest Neighbor
5.2.7.4 Choose your file name, click Okay.
6.0
Perform Unsupervised Classification
Next you will use image classification to build/extract different land use categories from
the LandSat images. Image classification “clumps together” different pixels based on
spectral signal, resulting in groups of pixels with similar spectral groupings. There are a
variety of classification methodologies. You will be performing unsupervised
classification.
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6.1 From the ENVI Main Menu GUI, select Classification > Unsupervised > ISODATA
6.2 Select your registered LandSat 5 data cube.
6.3 In the ISODATA dialog box, change Number of classes, Maximum Iterations and
other values to match the dialog below:

6.4 Enter Output Filename of you choosing, then click okay.
6.5 Load and display the registered LandSat 5 image as an RGB image in Display #1.
6.6 Display the ISODATA classification you completed above in Display #2.
6.7 Link the two displays and compare results.
6.8 Complete the analogous process for the LandSat 7 data cube.
7.0 Perform Post Classification (Sieve and Clump)
With the pixels grouped by spectral signature, you can set the number of pixel groups,
and the starting and ending thresholds for each group. From the ENVI Tutorial
documentation on classification, “Clump and Sieve are used to generalize classification
images. Sieve is usually run first to remove isolated pixels based on a size (number of
pixels) threshold, then clump is run to add spatial consistency to existing classes by
combining adjacent similar classified areas.”
7.1 From the ENVI Main Menu Window, select Classification > Post Classification >
Sieve Classes
7.2 In the Sieve Parameters Window, select the LandSat 5 data for which you performed
the unsupervised iso-classification.
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Leave the parameters as listed, enter a new filename and select OK.
7.3 The new “sieved” image appears in the Available Bands List.
7.4 Open the new classification in a new Display Window.
7.5 Link to your iso-classified image. Compare the results visually.
7.6 In the Main Menu Window, select Classification > Post Classification > Clump
classes
7.7 In the Classification Input File Window, select your sieved LandSat 5 data stack,
leave the parameters as listed, enter a new file name, click okay (see below).
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The new clumped image appears in the Available Bands List.
7.8 Open the new classification in a new Display Window.
7.9 Load the new clumped classification image, compare to the first sieved classification
image.
8.0 Group Classified Pixels into Land Use Categories
You will be grouping classified pixels into land use categories similar to the land
use categories in the National Land Cover Dataset (NLCD). The specific categories you
will use are: Null; Water; Forest; Developed Open Space; Developed Low Intensity;
Developed Medium Intensity; and Developed High Intensity.
You will use the classified LandSat 7 image as a baseline; you will classify the
LandSat 5 image so that the classifications between the two images are as similar as you
can make them. Specifically, you will use the classified LandSat 7 image, the clumped
LandSat 5 image and the LandSat 5 image you corrected to reflectance to classify the
LandSat 5 image.
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8.1 Open three windows in ENVI, as below, to begin classification of the LandSat 5
image.

8.2 In the Display Window, select Tools > color Mapping > Class Color Mapping

.
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8.3 In the Class Color Mapping Window, click on the categories under “Selected Class,”
compare the color of that class to the actual ground imagery.
8.4 In the Display Window, select Tools > Cursor Location Value. This will help you
tell which color class is which.

8.5 Based on your visual observation, under “Class Name:” rename the class (water, low
intensity, forest, etc) and change the color to be a color you associate with that land
cover.
8.6 After you name all of the classes, if any of the classes are the same (with 20 classes
you should have some of the same) go to the Main Menu Window > Classification > Post
Classification > Combine Classes
]
8.7 Select your classification image, select OK.
8.8 Select your input class (e.g., water1) and your output class (e.g., water), Select “add
combination”.
8.9 In the Combine Classes Output Window, under “Remove Empty Classes,” select
“yes”.
8.10 Name your new file, select okay, load your newly classified file.
8.11 Complete the analogous process for the clumped LandSat 7 image, again using the
LandSat 7 corrected to reflectance image as your baseline.
8.12 Load and compare just the classified LandSat 7 and LandSat 5 images, linking the
displays for closer examination.
8.12 When you are finished with classification, close ENVI.
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9.0 Download and Project Hydrography Data; Create a Project Geodatabase
USGS maintains a database of hydrographic data for the continental US. You
will download and unzip stream files from National Hydrography Dataset (NHD) for use
in the next phase of the project.
9.1 Point your web browser to http://nhd.usgs.gov/.

9.2 Use the Map Extent tool (left side-bar menu) to select the region approximating the
LandSat image area. Use the right side-bar menu to select datasets for regions, basins,
sub-basins.
9.3 A list of all datasets will pop up. Be sure to scroll down the window and set the
Database type to Personal Database ESRI 9.2 format. Provide your email address. When
notified, retrieve and unzip your data and save in a convenient location.
9.4 Open ArcCatalog to examine your data, and select the layers to work with.
9.5 Open the geodatabase (in my case, /CBF/NHD127506.mdb).
9.6 Open the Hydrography feature data set. Look at the NHDFlowline feature data class.
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9.7 Check the Metadata for NHDFlowline. Note that this data has not been projected.

9.8 Open the Hydrologic Units feature dataset. Examine the different feature classes, to
determine which to use. Select the Subbasin feature class.
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9.8.1 Examine the spatial properties for Subbasin. Note that like Flowline, Subbasin has
not been projected.
We will want to clip these two feature classes so that they approximate the LandSat
image area. First you will need to project Flowline and Subbasin—then clip them. After
clipping, you will then convert Flowline and Subbasin from shapefiles (vector files) to
raster files, to support your analysis.
9.9 Open ArcCatalog.
9.9.1 Create a geodatabase named “Erosion”.
9.10 Open ArcMap
9.10.1. Add Flowline and Subbasin.
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We will set the projected coordinate system for the Data Frame, then export Flowline and
Subbasin into our geodatabase using the Data Frame’s coordinate system. This is an easy
way to project our files.
9.10.2 In the TOC, right click Layers to bring up the Data Frame Properties dialog box.
Select the Source tab.
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9.10.3 Under “Select a coordinate system:” click the Predefined folder. Click Projected
Coordinate System > UTM > WGS 1984 > WGS 1984 UTM Zone 18N. See below:

9.10.4 Click Transformations.
9.10.5 Use the drop down arrow to select a Geographic Transformation method
(highlighted below). (Make a note of the transformation you use, as you want to be
consistent and use the same transformation with all your data).
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9.10.6 Click OK. Click OK.
9.10.7 Export your shapefiles as projected feature classes.
9.10.7.1 Right click NHDFlowline in the TOC. Click Data > Export Data to bring up the
dialog box below:

9.10.7.2 Change the radio button to use the same coordinate system as: “the data frame”.

9.9.7.3 Browse to your GDB, name and save your exported NHDFlowline as a feature
class. (NOTE: be sure to limit the name to eight characters, as you will be converting
this feature class to a raster.)
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9.10.7.4

Click Save.

9.10.7.5 Click OK.
After processing, you will get a dialog box that asks you if you want to add your new
feature class to your existing map.

9.10.8 This lets you know that your projection was successful. Click Yes.
9.10.9 Go through the same process for the Subbasins shapefile, creating a projected
Subbasin feature class in your Erosion GDB.

10.0 Export LandSat Images from ENVI into the Project Geodatabase
Adding the classified LandSat 5 and LandSat 7 images into your geodatabase
assists with data management. From the geodatabase, the classified LandSat imagery can
be added to your ArcMap project with the other layers, helping you visualize the final
product.
10.1 Open ENVI, and load both of the classified LandSat images (LandSat 5 and LandSat
7).
10.2 From ENVI, export each image to your Erosion geodatabase.
10.2.1 From the ENVI Main Menu click File > Save File As > ArcGIS Geodatabase
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10.2.2 Select the appropriate file (the classified LandSat 5 image in this case):

10.2.3 Click OK.
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10.2.4 The Select Geodatabase dialog opens. In the dialog box below, I have already
browsed to the Erosion GDB. I have also named the classified LandSat 5 image file as
L5_ENVI:

10.2.5 Click OK. ENVI will export the image file into your Geodatabase; as part of this
process, all the projected coordinate system information is also placed in the GBD with
your image file.
10.2.6 Complete the same process for the classified LandSat 7 image, exporting it to your
GDB.
10.3 Close ENVI.
11.0 Preprocessing a Digital Elevation Model (DEM)
An USGS DEM is a raster dataset with elevations. Later in this lesson you will
use a DEM to derive slope, an input to your erosion potential model. But first, you will
mosaic two downloaded DEMS (“stitch them together”). You will then project the
resulting single DEM into the same coordinate system as the rest of your data, WGS84
UTM18N.
11.1 Down load the two DEMS from USGS, then unzip the two files.
11.2 Open an empty ArcMap and add the two DEM rasters.
(You will get a dialog box asking you if you want to build pyramids, select “yes”.)
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Note that the shading in the raster is distinctly darker in one raster than the other. Look at
the values in the TOC for the reason why this is so…
11.3 Mosaic the DEMs into a Single DEM.
11.3.1 Open ArcToolbox > Data Management Tools > Raster > Mosaic
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11.3.2 Click the Mosaic tool.
11.3.3 Fill out the Mosaic dialog box, with one of the rasters (DEMs) in the Input Raster
box, and the other raster (DEM) set as the Target Raster. (You will be appending one
raster (DEM) to the other raster (DEM)). Leave the other values as set; your Mosaic
dialog should look like the one below: (Note: you may have to browse the raster (DEM)
to which you are appending (the Target Raster). ArcGIS may not let you “drag and
drop” the Target Raster from the TOC into the Mosaic dialog box.)

11.3.4 Click OK to run the process.
11.3.5 To verify your work, go to Full Extent in ArcMap.
Turn the target raster (DEM) you to which you appended on and off to see the difference.
(You may have to re-arrange the order of the layers so that the target raster (DEM) is
below the other raster (DEM) in the TOC.)
11.4 Project the mosaiced (appended) DEM.
11.4.1 Check the metadata for the appended DEM. You will see that the DEM has not
been projected:
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11.4.2 Open ArcToolbox > Data Management Tools > Projections and Transformations
> Raster > Project Raster

11.4.3 Double click Project Raster to open the dialog box.
11.4.3.1 Select the appended DEM as the Input Raster.
11.4.3.2 Click the Ouput Raster Coordinate System. Navigate to and select WGS 1984
UTM Zone 18N (see below):
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11.4.3.3 Click Add.

11.4.3.4 Click OK.
11.4.3.5 Set the Geographic Transformation to NAD_1983_To_WGS_1984_8. (Keep
track of this transformation. You will want to use the same transformation for all your
data.
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11.4.3.6 Set the Output Raster Dataset to save the DEM in your Erosion GDB.
11.4.3.7 Set the Output Cell Size to 28.5 (to match your LandSat Image cell size).
Your completed dialog box should look like the one below: (Note: For purposes of this
lesson, I have named this file “DEM”. You are encouraged to name your analogous
file something different, as using the file name DEM may conflict with ArcGIS scripts
and/or geoprocesses.)

11.4.3.8 Click OK.
11.4.4 Your appended, projected DEM is added to the TOC.
11.4.5 Check the spatial reference for DEM.
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11.4.6 Remove the two DEM rasters from the TOC, keeping only the mosaiced,
projected DEM from your Erosion GDB in the TOC.
11.5 Add the Subbasin and Flowline feature classes from the Erosion GDB.
11.6 Add the two classified LandSat images (rasters).
11.7 Zoom out to full extent.

11.8 Re-order the layers.
It is obvious that we have different extents in our datasets. To resolve this, we will “clip”
all the datasets with the DEM dataset. (The DEM dataset has the smallest areal extent.
We will have to do some slight modifications, as the DEM dataset does extend outside
the other data sets in some areas by a small bit in the southwest portion.) By reducing the
size of the rasters that we are analyzing, we can reduce geoprocessing time.
12.0 Converting Vector Files to Raster, “Rasterization”
Your analysis will make use of some powerful overlay tools available when
working with raster data sets. Therefore, you must first convert all vector files into raster
files.
12.1 Enable the Spatial Analyst extension. From the Main Menu bar: Tools > Extensions
> Spatial Analyst
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12.2 Also turn on the Spatial Analyst toolbar. From the Main Menu bar: View > Toolbars
> Spatial Analyst.
12.3 Using the drop down arrow on the Spatial Analyst tool bar set Spatial Analyst >
Convert > Features to Raster. The dialog box below shows the Flowline vector file set
up for conversion to a raster file:

12.4 Click OK. The dialog box below appears. Note the cell size.
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12.5 Set the Name for the raster and the Location. Then click Save.
12.6 Select your new raster in the table of contents. Right click, and make your way to
the Symbology Tab. Symbolize the new raster appropriately. (In this case, each stream
or river was added individually, and the respective name displayed.

12.7 Follow the analogous procedure for the Subbasin vector file, first rasterizing it, and
then symbolizing it appropriately.
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12.9 Add soils. Follow the analogous procedure for the Soils vector file, first rasterizing
the vector file, and then symbolizing the new raster appropriately.
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13.0 “Clipping” the Extent of the Raster Datasets (Using a Raster Mask)
So that we can make comparisons of the area subject to various levels of erosion (hence,
the potential for sediment), we need to ensure that we are analyzing layers (rasters) that
are all the same size (area). In vector geoprocessing, we would do this by clipping all
layers with a common shape. We can get the same result in our raster data by creating a
mask, and then limiting geoprocessing in all raster layers to the area that falls within the
boundaries of the mask. Accordingly, you will first create a raster analysis mask (a
polygon raster shape).
13.1 Open ArcCatalog.
13.2 Right click Erosion GDB. Click Make new Feature Class. (Note: for illustrative
purposes, I have named the raster polygon feature “Mask”. You are encouraged to use a
name other than “Mask”, as this name could conflict with various ArcGIS scripts.)
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13.2.1 Click Next.
13.2.2 Browse to the proper coordinate system for the raster mask, WGS 1984 UTM
Zone 18N (see below).

13.2.3 Click Next, Next, Finish.
13.3 Add the Mask feature class to your project.
13.4 Open and edit session, and digitize a polygon for the Mask feature class.
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Shouldn’t the Mask be in the same coordinate system as you raster data?
13.4.1 Start Editing.
Create a polygon just slight smaller than the DEM layer, but with all layers
underneath included. (I had to make a little “jog” in the “southwest” corner—see below.)
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(Note: Be sure Data Frame is set to coordinate system WGS84 UTM18N.)
13.4.2 When you are satisfied with your edits (the shape and extent of your polygon
mask), stop editing (saving your edits).
14.0 Deriving Slope from a DEM.
Recall that the DEM you preprocessed earlier is an intermediate step on your way
to developing your erosion/potential sedimentation model. Now you can use the DEM to
derive slope (rise over run), measured in per cent or degrees. You are interested in slope,
because slope measures the steepness of an area; steeper areas more susceptible to
erosion.
14.1 Click Spatial Analyst > Surface Analysis > Slope
14.2 Set the mosaiced DEM as the Input surface; select degree for the Output measure;
keep 1 as the Z factor; be sure the output cell size matches that of your LandSat images
(28.5m); and define an appropriate name and the path for the resulting raster.

14.3 Click OK.

14.4 Click Save. The slope raster is now added to your ArcMap project, as well as saved
to your geodatabase.
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15.0 Computing Distance from Stream Centerline; Adjusting Raster Mask Size
In addition to slope, the distance a given cell is from a river or stream centerline is
also correlated with how much eroded material actually makes it to the stream, ending up
as sediment. You will use the Straight Line distance tool in Spatial Analyst to compute a
distance value for each raster cell in the stream layer.
15.1 Click Spatial Analyst > Distance > Straight line
15.2 Set the raster stream layer in Distance to; select 5000 for Maximum distance; be
sure the output cell size matches that of your LandSat images (28.5m); and define an
appropriate name and the path for the resulting raster.

15.3 Click OK.
15.4 With distance calculated, re-open an edit session. Adjust the mask so that it does
not extend beyond the smallest layer (see result below).
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16.0 Preparing for Raster Analysis; Reclassifying Variables
In raster analysis you will take advantage of the properties of each raster layer,
examining the relationship between them on a cell-by-cell basis. In the very simple
model you will use, the cells in each layer will be set to integer values (non-decimal
values) and grouped by these integers into categories. You are already familiar with this
concept, employing it when you classified the cells in the LandSat images into discrete
land use categories. You will make analogous classifications for each raster layer.
16.1 Reclassifying the Distance Raster
For our model, we will postulate that more sediment is carried to a river or stream
by cells that are closer to the stream centerline than by cells that are further away. We
will model this behavior—the sediment transportation potential of each cell-by
reclassifying our stream distance raster.
We will assume that the amount of sediment a specific cell can transport
decreases by the inverse of the cell distance squared from the stream centerline.
Sed = 1/d2
To set up our raster to model this, we will collapse the floating point values (“Old values”
in the table below) into new, integer values. (Note that the Old values are meters away
from stream centerline. The New Values you are creating represent the ability of cells to
transport sediment to the stream. So, cells that are closer than 499.953711 meters from
the stream centerline can carry 16 times the amount of sediment to the stream as cells that
are 2499.768555 meters or further from the stream.) (Yes, you are completing two steps
at one time in this process—both setting floating point values to integer values, and
assigning the integers to categorical (or “dummy”) values.)
16.1.1 Use the table below to set the new values (note that some of the old values in the
Reclassify dialog are “collapsed” into new values):
Old values
New values
0 – 499.953711
16
499.953711 – 999.907422
4
999.907422 – 2499.768555
2
2499.768555 and greater
1
No Data
-99
These values reflect sediment transportation model discussed above. You will also set “99” as the value for cells with contain No Data. This is a geoprocessing “trick,” as you
can easily determine that any cell with a negative value in future calculations was a No
Data cell at one time.
16.1.2 Click Spatial Analyst > Reclassify
16.1.3 Browse to the stream distance raster you created previously
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16.1.4 Using the table in 16.1.1, set the New values. (Note: you will have to scroll down
in the Set values to reclassify dialog box.

16.1.5 Browse to set the path for the Output raster, also giving it an appropriate name.
In the example below, I have named the Output raster Dist1_class and am saving it to the
CBF folder:

16.1.6 Click Save. Click OK. Your result should resemble the output below:
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16.2 Reclassifying the Slope Raster
We need to reclassify slope, so that we can model a behavior in which cells with
steeper slope have the potential to transport more material to the stream, where it
becomes sediment. To build this model, you will use the same reclassification
methodology as you used previously to reclassify and model the effect of cell distance
from stream centerline on sediment transportability.
16.2.1 Use the table below to set the New values to reclassify the Slope raster. (Note that
some of the old values in the Reclassify dialog are “collapsed” into new values):
Old values
New values
0 – 5.805355
1
5.805355 – 15.367116
3
15.367116 – 20.830979
5
20.830979 and greater
10
No Data
-99
In this model, “flatter” cells (those with lower slope values) have less potential to
transport material to the stream. So, cells with slopes ranging from 20.830979 degrees or
greater have the ability to transport 10 times the material than do cells with slopes from 0
degrees to 5.805355. Again, you will set “-99” as the value for cells with contain No
Data.
16.2.2 Click Spatial Analyst > Reclassify
16.2.3 Browse to the slope raster you created previously
16.2.4 Using the table in 16.1.1, set the New values. (Note: you will have to scroll down
in the Set values to reclassify dialog box.
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16.2.5 Browse to set the path for the Output raster, also giving it an appropriate name
(e.g., Slope_reclass).
16.2.6 Click Save. Click OK. Your result should resemble the output below:

16.3 Reclassifying the Soils Raster
If you examine the N15 field for the soils raster you created, you will see that the
soils are classified from Very Poorly Drained to Excessively Drained. For our model,
assume that Very Poorly Drained soils have the least potential to transport sediment, and
that Excessively Drained soils have the greatest potential to transport material to a
stream.
Use the same reclassification methodology as you used previously with the
Distance and Slope rasters to reclassify the Soils raster. (NOTE: it is important to use
the drop down arrow in the “Reclass field:” to set N15.)
16.3.1 Use the table below to set the new values (note that some of the old values in the
Reclassify dialog are “collapsed” into new values):
Old values
New values
Excessively drained
8
Moderately well drained
5
Poorly drained
3
Somewhat excessively drained
7
Somewhat poorly drained
4
Very poorly drained
1
Well drained
6
No Data
-99
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16.3.2 Save as soil_reclass and run the process. Your result should resemble the output
below:

16.4 Reclassifying the LandSat images
In the steps below, you will assign integer (“dummy”) values to weight the different land
use types you classified previously in the two LandSat images.
16.4. 1 In ArcMap and add the two classified LandSat image files from your GDB to
your project.
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A screenshot of the Table of Contents for the classified LandSat 5 image (from the GDB
follows):

16.4.2 Next add the two “true color” (RGB) LandSat image files (*.img). You will use
LandSat image files as baselines, so that you can manipulate the classified LandSat
images (from your GDB) to weight the land uses appropriately.
The Table of Contents (TOC) for the “true color” (RGB) LandSat image (NOT the image
from the GDB) is below:

Compare each classified image with its analogous “true color” image to see the
differences. Also examine the TOC for each image.
16.4.3 Click Spatial Analyst > Reclassify to open the Reclassification dialog for the
appropriate reclassified LandSat image (the reclassified LandSat 5 image in the example
below).
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16.4.4 Analogous to previous reclassifications, use the table below to complete the
reclassification parameters. (For example, the Old Vales for the first row are a black
polygon, Unclassified and 0. The Old Values for the second row are a red polygon, Null
and 1.) Set the New Values as indicated below:
Old values
0
1
2
3
4
5
6
7
8
9
No Data

New values
-99
-99
10
9
6
5
4
2
3
1
-99

16.4.5 Set the path and name for the output raster:

16.4.6 Click Save. Click OK.
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16.4.7 Complete the analogous process for the other image file (the LandSat 7 image).
Set the values below for the LandSat 7 image.
Old values
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
No Data

New values
-99
-99
10
10
10
10
10
9
9
5
6
4
3
1
1
2
-99

16.4.8 From the Symbology tab under Layer Properties for each of the reclassified
LandSat images, apply the Red to Green, Diverging Bright color ramp to both of the
images. Flip the colors. Change the color for the Value - 99 to black, and the color for
Value 10 to Ultra blue.
16.4.9 Compare the resulting classified images to notice the differences. Compare the
number of cells in each class between the Classified LandSat 7 image and the classified
LandSat 5 image. (My results are below. Your results will be different, but should be
similar)
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What values did you get? Take screenshots of the attribute tables for each classified
LandSat image you produced.
How well do the classified images match the respective “true color” images?
17.0 Raster Weighted Overlay—Exploring a Model for Sediment Potential
With all the preparation completed, you can now use map algebra to develop a
measure for the sedimentation potential. A very simple model for analysis follows
below:
Sedimentation potential = Distance * Slope * Soil Drainage * Land Classification Image
Using the concepts and procedures mastered in this lesson, much more
complicated (accurate) models could be developed. (A search of the Internet for the
terms water, erosion, soil, NRCS will lead you to a variety of more complicated models.)
The model above is not intended for real-world use.
You will complete an analysis of the potential for the classified LandSat 5 image,
and for the classified LandSat 7 image using the Sedimentation model above. You can
then compare the results, contrasting the number of cells potentially contributing to
sedimentation in each image. You can also determine which cells are more likely to
contribute greater sediment loads. Finally, you will calculate the area of sedimentation
for each classified LandSat image.
17.1 First, set up the Geoprocessing environment.
17.1.1 From the ArcMap Main Menu click Tools > Options. Click the Geoprocessing
tab. In the middle of the Options dialog box, click the Environments button to open the
Environment Settings dialog box.
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17.1.2 Click General Settings, and fill in the General Settings as below:

17.1.3 Scroll down the Environment Settings, to set up the Raster Analysis Settings, also:

17.1.4 Click OK. Click OK.
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17.2 Running the Model; Using Raster Weighted Overlay
You have now completed all the steps in preparation of running your
sedimentation model. You will run the model two times, first for the May 1987
reclassified LandSat image (L5_reclass), and then for the October 2001 reclassified
LandSat image (L7_reclass).
17.2.1 Navigate to ArcToolbox > Spatial Analyst Tools > Weighted Overlay.

17.2.2 Double click to open the Weighted Overlay dialog box.
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You will use the “+” icon to add the four rasters for the May 1987 reclassified LandSat 5
image (L5_reclass) model: dist1_reclass * slope_reclass * soil_reclass * L5_reclass.
Patience is important in this process, as you will have to wait for each raster to finish
loading before you can load the next.
17.2.3 Click the “+” icon.

17.2.4 The Input raster dialog box comes up. You can use the drop down arrow or
browse to dist1_reclass. Select dist1_reclass and click Add.
Dis1_reclass is now in the Input raster field of the Add Weighted Overlay Layer dialog
box.

17.2.5 Click OK.
The Weighted Overlay dialog box comes up. Ignore the error and warning, and
the red “stop” symbol. (You are getting these errors because you have not yet assigned
the % influence for this raster. You will assign these percentages after you have added
all the rasters.)
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17.2.6 Click the “+” icon again. Using the same method as for dist1_reclass, add the
slope_reclass raster. NOTE: patience is important in this process—you will have to wait
for each raster to finish loading before you can load the next.

17.2.7 Using the same process, add soil_reclass and L5_reclass in turn. With all four
rasters added the Weighted Overlay dialog box should look like the example below (note:
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you see two screen shots because I have scrolled down the list of rasters in the Weighted
Overlay so that you can see all four rasters):
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17.2.8 Now you can assign the appropriate % influence to each raster, and clear up the
error and warning message. Use the values in the table below to assign % influence:
Raster
Dist1_reclass
Slope_reclass
Soil_reclass
L5_reclass

% influence
5
35
10
50

17.2.9 After assigning the % influence, you will see the Sum of influence go to 100 (see
below). Browse to the location where you want to save your weighted raster. (In the
Output raster dialog box below, I am saving the output raster as L5_weigh in the CBF
folder.)

17.2.10 Click Save. All the error and warning messages, and the red stop icon disappear.
Click OK.
17.3 Complete the analogous process for the October 2001 reclassified LandSat 7 image
(L7_reclass). (Note: be sure you use L7_class and not L5_class for this iteration of the
model!) Save the output raster as L7_weigh. Run the geoprocess.
17.4 Resymbolize the each of the “*_weigh” rasters, using the Red to Green Diverging,
Bright color ramps. Flip the colors. Change the color for <VALUE> 1 to ultra blue.
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Part 3 - Analysis
Outlined below are some simple analyses. These are merely points of departure for
further research on your part. To illustrate this point, consider just three observations:
1) It would be beneficial to run multiple iterations of the weighted analysis for
each classified LandSat image, changing the factors (distance, slope, and soils) in logical
fashion, and examining the results.
2) Some form of “ground-truthing” the sedimentation model outputs is essential
to evaluating how well the model performed, and to developing a more accurate analysis.
3) A more complex model, with the current factors decomposed further, would
also provide a more accurate model—as is clear from examination of the considerable
NRCS body of research in this area.
Despite these caveats, let’s examine the results of our simple model.
Add or move the flow layer to the top of the TOC, so that you can see where the streams
are.
Add both the unclassified (“true color” or RGB) images to your ArcMap project (if niot
already included) to give you both base photos.
For a visual inspection, click the respective layers (e.g., weighted LandSat 5
sedimentation model and the LandSat 5 unclassified image) on and off to see the
differences.
For a more quantitative examination, first note that we are comparing like to like. We
have the overall same number of cells (sum = 17726840 for each raster) (below):
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Recall that higher values are prone to greater sediment transport.
Compare the attribute tables between 1987 and 2001 and note the differences in
categories:

Entering the data into an Excel and producing simple chart yields the following:
Sediment Potential
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Index
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6

7

8

- Index value 1 represents water (rivers and streams). There is approximately 16%
more water in 2001 than in 1987.
- Index 2 represents areas not prone to sediment transport. In 2001 there is about
37% more land in this category than there was in 1987.
- Index 3 represents areas mildly prone to sediment transport. In 1987 there was
about 60% more land in this category than there was in 2001.
- Index 4 represents areas mildly prone to sediment transport. In 1987 there was
about 41% more land in this category than there was in 2001.
- Index 5 represents areas prone to sediment transport. In 2001 there was about 7%
more land in this category than there was in 1987. Note that the amount of land in
this category remained approximately the same between 1987 and 2001.
- Index 6 represents areas even more prone to sediment transport. In 1987 there was
about 46% more land in this category than there was in 2001.
The land areas represented by index values 7 and 8 are both very small. Commenting
on these areas, given the imprecision in the analysis tools, is not warranted.
To complete this project, you are to conduct your own analyses and present the
results to a decision maker for consideration. You may find the preceding discussion
a helpful outline. Recall that the purpose of this exercise was to examine
sedimentation potential, identifying areas with greater potential, and developing
insight into how this potential has changed over time. Analysis for its own sake, like
a map that is never viewed, is of extremely limited utility.
You are to write a brief paper and build a 10-minute Powerpoint presentation
covering the results of your analysis (requirements and rubrics for both the paper and
the presentation will be provided). Be sure to use geovisualization techniques, tables
and graphs, and other analytical tools to illustrate your findings. Also be certain to
document your assumptions and the limitations of your study—better analyses
include such information.
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