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Overview of Topic   

This project focuses on the St. Louis River watershed located in northeastern Minnesota and northwestern 
Wisconsin.  The watershed covers portions of Lake, St. Louis, Itasca, Aitkin, and Carlton counties in 
Minnesota, and Douglas County in Wisconsin.  The watershed covers approximately 3900 square miles of land 
of various land cover types.  Land cover has a direct impact on the behavior of water within the watershed, both 
from atmospheric and land-based sources.  For instance, the presence of urban land cover, typically comprised 
of impervious surfaces, will increase surface run-off rates significantly.  Alternately, forested wetland land 
cover will tend to collect water, therefore reducing surface run-off rates.  In order to understand what is 
occurring within the watershed, it is important to first understand the relationship between the extent and type of 
land cover within the watershed.    

The objective of this project is to create a map of land coverage of the St. Louis River watershed for 2003.  
Performing land cover classification of data from 2003 will allow us to establish a baseline, or a point that you 
can perform analysis forward from. Once a baseline has been established, future land cover classification can 
identify areas of land cover change, from activities such as wildland fires, logging, and urban growth.  

Data used to perform a land cover classification will consist of Landsat 5 (L5) imagery and a vector shapefile of 
the watershed.  L5, which included the Thematic Mapper (TM) sensor, was launched in 1984, and has been 
providing continuous data collection since then.  L5 imagery provides data from seven bands, or specific 
regions of wavelengths within the electromagnetic spectrum.  Various combinations of these bands can produce 
red-green-blue (RGB) color composite images that enhance certain significant features within these images, as 
you will see.    The land cover classification will be created from processed L5 data.  This classification will be 
performed in ENVI+IDL remote sensing software.  A final product will be exported and viewed in ESRI’s 
ArcGIS software.  A map created in ArcGIS will serve as the final product of this project.     
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Step 1.  Explore Landsat Imagery    

Launch ENVI + IDL and from the main menu tool bar go to File > Open 
External File > Landsat > GeoTIFF.  Navigate to your student folder and 
select the files that correspond to Bands 1-5 and 7 of the Landsat TM image 
for Path 27, Row 27.   Click Open and the Available Bands List will appear.     

Why are there multiple bands in each scene of 
Landsat imagery?       

Explore the bands by selecting various RGB combinations and loading them into a 
display window.  Do this by selecting the RGB Color radio button, and then selecting 
three of the bands in the bands list to apply red (R), green (G), or blue (B) color to.  
You must click on the “Band 1” notation under the band name to load it.  Once you 
have selected three different bands, click Load Band and view the result in the display 
window.  Specific band combinations tell you about the surface of the Earth.  For 
instance, selecting band 4 (B4) for red, band 3 (B3) for green, and band 2 (B2) for blue 
will render a display as seen here.  The display shows the extent of vegetation within a 
portion of the image in red tones, roads and bare ground in light blue, and lakes in 
black.  As you will note, there is a significant amount of vegetation in the scene you are 
working with.   Different surfaces will reflect and absorb different amounts of energy within specified regions 
of the electromagnetic spectrum.   

Explore some other band combinations.  List them below (such as 4, 3, 2) along 
with your observations of the display: 
Band combination #1:  

Observations #1:       

Band combination #2:  

Observations #2:    

Band combination #3:  

Observations #3:  
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When you have finished exploring, close the image files.  

Step 2. Converting DN to Radiance 
The sensors aboard a satellite record data for each pixel of an image based on the brightness of that area on the 
face of the Earth.  This data is recorded as a digital number (DN).  It is necessary to convert this number to 
more useful physical values such as radiance, reflectance, and temperature in order to derive meaningful 
information.  The conversion from DN to a physical value must take place on each band independently.  To do 
this, you will need to perform band math on each band using values from the following formula:      

Where:  

L

 

= Spectral radiance at the sensor’s aperture in W/(m2•sr•µm)  

LMAX

 

= Spectral radiance that is scaled to Qcalmin in W/(m2•sr•µm)  

LMIN

 

= Spectral radiance that is scaled to Qcalmax in W/(m2•sr•µm)  

Qcalmax = Maximum quantized calibrated pixel value corresponding to LMAX

 

(DN = 255)  

Qcalmin = Minimum quantized calibrated pixel value corresponding to LMIN

 

(DN = 1)  

Qcal = Quantized calibrated pixel value in DNs   

Qcal represents the pixel values within the respective band.  Qcal = B1, B2, etc…  The values for Qcalmin, Qcalmax, 
LMIN, and LMAX can be retrieved from the metadata file provided in the Landsat imagery folder for each 
scene.  The best way to access this information is to open the text file L5027027_02720030905_MTL from your 
Landsat folder containing the scene with Path 27 Row 27 imagery, copy all the information it contains (Ctrl + 
A), open a Microsoft Word document, and paste the information into that document (Ctrl + V).  This separates 
the information nicely and makes it much easier to find the values you are looking for.  Save this file for later 
reference.                  
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Using the information provided in the metadata file, complete the expression for the Path 27 Row 27 Landsat 
imagery.  For Band 1 of the Path 27 Row 27 image the expression would be as follows:    

L = ((193.0 – (-1.52))/(255-1)) * (B1 – 1) + (-1.52)  

Part 1: Composing Expressions for Converting from DN to Radiance 
Record the expressions for Bands 1-5 and 7 prior to proceeding below:  

Path 27 Row 27

  

B1:           

  

B2:           

  

B3:           

  

B4:           

  

B5:           

  

B7:           

  

Now compose the expressions for the conversion using Path 27 Row 28 information (make sure to access the 
metadata for that scene to input the correct values for all variables).  

Path 27 Row 28

  

B1:           

  

B2:           

  

B3:           

  

B4:           

  

B5:           

  

B7:           

  

Compare the above expressions.  Are they similar?  Why do you think this may be?     

Part 2: Applying Band Math 
To apply this in ENVI as band math, follow these steps: (this will be done to both scenes separately)  

Path 27 Row 27 Imagery

  

Launch ENVI+IDL from the Start menu.  From the Main Menu, select File > Open Image File and 
navigate to the folder provided for you with Path 27 Row 27 imagery.  Open Bands 1-5 and 7 of the 
provided L5 image.   
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Make sure to note that each band can be distinguished by the indicator at the end of the 
file name.  For instance, Band 5 is named LT5027027000324850_ B5.tif.  B5 indicates 
that this file is Band 5.           

 

Next, launch the Band Math function by navigating 
from the Main Menu to Basic Tools > Band Math.  
Enter the formula from above into the expression 
window for Band 1 as such.  Select Add to List.  Select 
OK.          

The Variables to Bands Pairing window will appear.  You will need to indicate 
what B1 refers to, also known as defining the variable in the expression.    

 

Select Band 1 in the Available Bands List by clicking on “Band 1” under 
the appropriate file name corresponding to Band 1 (B1) as shown to the 
right.  

 

Click on the Choose button, which allows you to “choose” your file name 
and location, and browse to the location that you wish to save this file in and 
select a name.  The output location should be indicated by your instructor.  

Helpful Hint: When selecting a name for the converted file, it is important to 
consider what modifications have been made to the file.  When working with 
numerous images for one scene, and potentially numerous scenes, it is a good 
idea to adhere to a consistent naming convention.  For this exercise, use 
L5_027027_ B1Rad for the converted Band 1 file output.  This preserves the 
information on sensor, path and row, band number, and notes the modification 
that was made to the file.  Select OK.  

 

Load the new image file into a display window, and the corresponding band prior to conversion into 
another display window.  Link these windows (from Display window, Tools > Link > Link Displays) 
and open the Cursor Location/Value tool (from the Display window, Tools > Cursor Location/Value).  
Compare the data values in both images.  How have the data values changed between the two images?   

ANSWER:___________________________________________________________________________ 
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Repeat the steps to convert remaining bands from DN to radiance making sure to enter the respective 
expression for each band into the Band Math window.    

Helpful Hint: Once you have entered all the formulae and added them to the Band Math window, click Save 
and save the file in the same location as your imagery.  If you make a mistake, or need to come back to the 
band math in the future, you will only need to click Restore to access the formulae rather than retype them 
all again.  Save your band math file as BandMath.  You will continue to add to it, or restore it if you must 
end your session prior to continuing on at any point in this tutorial.   

 

Complete the above steps to convert Path 27 Row 28 imagery from DN to Radiance.  Once you 
have completed converting, remove all the original files from the Available bands list so you only have 
the image files that have been converted to radiance remaining.   

Part 2: Calculating Band Statistics 
At this point it is a good idea to calculate the Band Statistics on all processed bands to verify that you have 
acceptable values.    

 

On the Main Menu bar, select Basic Tools > Statistics > 
Compute Statistics.  A Compute Statistics Input File 
window will appear with all the bands in your Available 
Bands List shown.  You will note that in this example, all 
the original files have been closed prior to beginning this 
step.  If you have not done so, there is no issue.  It is 
good practice, however, to keep the list of files that you 
are working with as simple and concise as possible.  You 
may either cancel here and close the original L5 image 
files, or continue and do so at a later time.   

 

Select Band 1 of Path 27 Row 27 imagery so that it is highlighted and click OK.  This will launch the 
Compute Statistics Parameters window.  Here, you can select whether you want the output Band 
Statistics file to include a Histogram, and customize your output as desired.       

 

Make sure that the Basic Stats, Output to the Screen, and Output to a 
Text Report File boxes are all checked as shown to the left.  Click on 
Choose to navigate to the location you are storing your P27R27 (Path 27 
Row 27) converted bands, and enter 2727_B1Stats.txt for the file name.  
This arrangement will allow you to view the statistical output on the 
screen as well as save it in a text file format.  Select OK.            
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Once the statistics have been computed, a Statistics Result window will 
appear with the results of the run.   As you will note, there appear to be 
negative values in the data set.  This should not be the case, and must be 
rectified before proceeding to the next step (converting radiance to 
reflectance).    

 
First, continue running the statistics for all bands saving the output 
text files according to the respective band and path/row you are 
computing statistics on.    

Once you have completed compiling the statistics for all bands, open the 
text files.  We will aggregate all the data from these files for housekeeping 
purposes.       

 

Using a Windows Explorer, navigate to the location in which you saved the 
output text files.         

 

Open these text files, copy the information from each and paste it into one text file keeping all the band 
statistics arranged in order of Band 1-5 and 7.  Save that text file as Compiled.txt.  Do this for both 
path/row scenes, naming P27R28 Compiled2.txt.  You can then delete all the individual text files 
leaving your compiled text file remaining with the converted image files.               

By reviewing the text file, you can see that all bands contain negative values.  Upon consultation with 
scientists specialized in Landsat TM data analysis, it was determined that these negative values could be 
converted to zero values and still maintain the integrity of the data set.  It is not advisable to simply convert 
negative values without review of the possible reasons and the processes that led you to them.  In this case, 
it has been verified.  To do so, we will again perform a band math function.  This time, we will be using the 
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included neg2zero.pro function written by scientist Richard Irish from the NASA Goddard Space Flight 
Center.  

Part 3: Applying an IDL Function 
In your folder containing the L5 imagery, you will note there is a copy of the neg2zero.pro file.  You will be 
using this function to convert the negative numbers in the data set to zeros.  

 
On the ENVI Main Menu bar, select File > Compile IDL Module, navigate 
to its location and select it, then click Open.  This loads the function into 
ENVI.  Next, open the Band Math tool again (Main Menu, Basic Tools > 
Band Math) and enter the phrase: neg2zero(B1)     

 

Click on Add to List and you will see it appear in your list of expressions.  
Click OK.  Once again, you will need to define the B1 variable.  Do so by 
selecting the converted Band 1 (make sure you are selecting the correct image 
file by verifying the band number in the image file name).  Click Choose and navigate to your 
workspace, create a new folder to store these files in (2727_RadZero), and name the output file 
L5_027027_ B1RadZero.   

Once the new image file has been created, it will load at the top of your 
Available Bands list.  Before running the function on any other bands, let’s 
ensure that it has in fact done its job.    

 

Compute statistics on the new image file (Main Menu, Basic Tools 
> Statistics > Compute Statistics).  This time, do not check the 
Output to Text Report File box and run the statistics.   

View the results of the band statistics.  Compare the values to those in the 
Compiled text file.  Does the Max value correspond to the maximum value 
in the band file that was converted to radiance prior to removing the 
negative values?    

ANSWER:__________________________________________________________________________  

 

If no negative values are present and the Max value has not changed, you can continue on with the Band 
Math [neg2zero(B2)] replacing the band variable with the corresponding band number you are applying 
band math to.  Save the output files as previously outlined.  Ensure that the negative numbers have been 
converted to zeros for the bands using the statistics function as you progress through this step.  

 

Once you have completed this, it’s time to move on!     

BUT FIRST…    
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Part 4: Using ENVI’s Preprocessing Calibration Utilities 
Let’s attempt to do this using ENVI’s built in preprocessor to compare the results.     

 
Load the original P27R27 L5 bands provided to you so that they are in the 
Available Bands List along with your recently converted radiance bands 
(negative values removed) for the same path/row.   Under Options, select Fold 
All Files.  This will minimize the extent of the files while still providing a list 
of the image files you have available as shown to the right.            

 

From the Main Menu, select Spectral >  Preprocessing 
> Calibration Utilities > Landsat TM.  The TM 
Calibration Input File window appears.  Select the 
original preprocessed Band 1 image file as shown to the 
left.  Click OK.         

The TM Calibration Parameters window appears.    The acquisition date and sun 
angle are contained in the metadata file for the scene.  Navigate to the folder with the 
original L5 images you were provided and open the metadata file 
(L5027027_02720030905_MTL.txt).  This is the same file that you previously used 
to determine the Qcalmax, Qcalmin, LMAX, and LMIN values.   If you previously copied 
the metadata to a Microsoft Word document, you can access it instead to find the 
required information.  Scroll down through the metadata to find the following and 
record the following items here:  

Acquisition date:___________________  

Sun Elevation:______________________  

 

Select Landsat Satellite 5.  Enter the above information in the parameters window.  The minimum and 
maximum values are the LMAX and LMIN values that you used at the beginning of this section (in the 
L5027027_02720030905_MTL.txt metadata file).  Make sure to use the values that correspond to this 
image acquisition date.  Select Radiance, click on Choose and navigate to the location you wish to save 
the output files, create a new folder named ENVI_Rad, and name the file 2727_B1_ENVIRadTest.  
Click OK.  When it is complete, compile the band statistics.    

Perform this preprocessing on all 6 bands and compare results.  Name each of the output files as shown above, 
changing the band number to represent the band you are working with (for example, change B1 to B2 when 
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working with Band 2).  Record the differences below using the LMAX and LMIN from both the ENVI 
Preprocessing function and the LMAX and LMIN that you arrived at using band math (open the Compile text 
file to record the values):   

Band LMAX - ENVI LMIN - ENVI LMAX - Band Math

 
LMIN - Band Math 

Band 1  193 -1.52 193 -2.29 

Band 2      

Band 3      

Band 4      

Band 5      

Band 7      

  

This comparison illustrates the need to understand what is behind the functions of any application.  In this case, 
the preprocessing function would not

 

render correct values for the conversion from DN to Radiance.  We will 
disregard the files created using the preprocessing utility and continue on with the Radiance files that you have 
created and removed the negative numbers from.  

Step 3.  Converting Radiance to Reflectance 
Now that you have completed the conversion from DN to radiance, the next step is to convert the radiance 
values to top of atmosphere (TOA) reflectance.  Top of atmosphere reflectance refers to the surface reflectance 
values as they are received at the sensor, which is at the top of the atmosphere.    

To convert from radiance to TOA reflectance, you will need to perform band math on each band using values 
from the following formula:         

Where: 
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Photo credit: Thomas G. Andrews, NOAA Paleoclimatology Program  
http://www.ncdc.noaa.gov/paleo/slides/slideset/11/11_183_slide.html

  
Because the distance between the Earth and the Sun is constantly changing during the course of the year, it is 
important to calculate the correct distance to the date of image acquisition.  Time for some Earth Science!  

The Earth revolves around the Sun in an elliptical orbit.  It is 
closest to the Sun in early January, and furthest away in early 
July.  This results in differences in the amount of radiation 
received from the Sun.  Because the satellite receives energy 
that reflects off of surfaces on the Earth, it is important to 
know how much energy is coming into the Earth’s 
atmosphere to begin with.  Therefore it is necessary to 
calculate the distance between the Earth and the Sun at the 
time of image acquisition.  

It is also important to determine the tilt of the Earth with 
respect to the Sun.  As we know, we experience seasons due 
to the tilt of the Earth.  If it were due to the distance, 
according to the diagram to the left we would experience 
summer in the United States in December!  In the Northern 
Hemisphere, we receive more direct influx of radiation from the Sun during our summer season.  Since we are 
interested in the amount of radiation being reflected off of surfaces and thus captured by sensors such as 
Landsat TM, we must also determine the angle at which that radiation source (the Sun) is irradiating those 
surfaces.  

We have already calculated the spectral radiance, which is the band file you previously created when converting 
from DN to radiance (and then converted the negative values to zero values).  Now we will calculate the other 
parameters necessary to create the expression to convert to reflectance.   

Part 1: Calculating Earth-Sun Distance 
To calculate the Earth-Sun distance in Astronomical Units (AU), you can either extrapolate using the chart 
below, or perform the calculation for a more accurate figure.  One AU is the average distance between the Earth 
and the Sun, but remember that this distance changes over the course of the year due to Earth’s elliptical orbit.    

The L5 image that you have been provided with has an acquisition 
date of September 5, 2003, which is the 248th day of that year.  In the 
chart to the right, you see that the DOY column corresponds to the 
Julian Day of the year.  DOY 242 has a distance of 1.0092 AU, 
while DOY 258 has a distance of 1.0057 AU.  DOY 248 is about 3/8 
of the distance between the two.    

 

Calculate an extrapolated distance using the above figures 
below:   

d=  

However, if you are interested in more precise figures, let’s go through a set of more directive calculations:  

 

First, you must determine the exact Julian date.  Julian dates (JD) are continuously counted days 
beginning at 1200 hours on January 1, 4713 BCE.  They are complete with fractions to denote the time 
of day as well.  Time is provided in Universal Time Zone (UTZ), and is based on a 24 hour period rather 
than am and pm.  Locate and open the text file L5027027_02720030905_MTL.txt (or the Microsoft 

http://www.ncdc.noaa.gov/paleo/slides/slideset/11/11_183_slide.html
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Word document containing the metadata) from the original P27R27 L5 imagery.  It should be located in 
the folder with the original L5 imagery that you have been provided.  As you scroll through the file, you 
will see the scene center date and time.  Record them here along with the Sun Elevation:  

Sun Elevation:______________________  

Acquisition Date:___________________  

Date Hour Contact Period (Julian date and time):___________________  

 

Next, navigate to an on-line Julian date converter, such as 
http://www.usno.navy.mil/USNO/astronomical-applications/data-services/jul-date.  Enter the acquisition 
date and UTZ time that you recorded above.  What is the result?  

ANSWER:_________________________________________________________________________  

 

This will be your JD of interest.  Use this figure in the following equation to determine D:  

D = JD – 2451545.0  

D=  

D represents the number of days from noon on January 1, 2000.  Use this figure in the following equation, 
which is part of a calculation of the celestial coordinates of the Sun on the Julian Date.  You will calculate g, 
which is a constant, ensuring that you proceed according to the appropriate order of mathematical operations:  

g = 357.529 + (0.98560028 * D)   

g=   

Finally, use these in the following formula to determine R, which is the distance from the Earth to the Sun in 
AUs:  

R = 1.00014 – (0.01671*cos(g)) – (0.00014*cos(2g))    

R=  

A summary of this process can be found at: http://aa.usno.navy.mil/faq/docs/SunApprox.php.  

 

How does the value you found for the distance between the Earth and Sun compare to the value 
determined through extrapolating values to find d?   

ANSWER:________________________________________________________________________   

As we know from Kepler’s second law, a planet does not orbit at a constant speed.  Therefore, extrapolating a 
value will provide us with an estimate, but calculating out the exact value provides us with a much more 
accurate distance.  We will carry forward using the value that you calculated for the next expression.  

http://www.usno.navy.mil/USNO/astronomical-applications/data-services/jul-date
http://aa.usno.navy.mil/faq/docs/SunApprox.php
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Part 2: Composing Expressions for Converting from Radiance to Reflectance  

Solar exoatmospheric spectral irradiances (ESUN ) are provided 
here again for converting radiance to reflectance.  The solar zenith 
angle ( s) is determined by subtracting the Sun Elevation found in 
the metadata that you recorded earlier from 90 (in other words, you 
are determining the complement of the Sun Elevation angle):  

s = 90 – Sun Elevation  

s =   

You are now ready to compose the expressions to convert the L5 bands from radiance to reflectance.  Do so for 
Bands 1-5 and 7 in the space provided below, using the Band for L .  Band 1 would appear as follows:  

Reflectance Equation:   

      Band 1:  p = (3.1416 * B1 * (1.008232)) / (1957 * (cos 45.2588))  

Because the Band Math function requires a specific format for indicating exponents and trigonometric 
functions, you will want to record your equation either in a simplistic form or as directed in the ENVI help:               

According to ENVI help, your expression would appear as such:   

Band 1:  p = (3.1416*B1*(1.00823^2))/(1957*(cos(45.2588)))  

B1:           

  

B2:           

  

B3:           

  

B4:           

  

B5:           

  

B7:           

  



Determining Land Cover of the St. Louis River Watershed  

Using Band Math as shown in Step 2, Part 2, enter in the above formulas for converting from radiance to 
reflectance.  Define L

 
as the band derived in Step 2, Part 3 corresponding to the band you are converting (for 

Band 1, you should define B1 as the file L5_2727_B1RadZero).    

Save the files in a new folder in your student folder named 2727_Reflect.  Name the files 2727_B1Reflect, 
changing the band number to correspond to the band you are converting.  Save your BandMath formula file 
again, as well.  

Repeat this for P27R28 imagery.  You will need to determine the Sun Elevation from the metadata for the 
P27R28 imagery, but you will note that the Date Hour Contact Period is the same for both scenes so you will 
use the same Earth-Sun distance figure that you calculated earlier.  The scenes were actually acquired minutes 
apart during the same hour.  Apply the expressions to each image in the P27R28 scene following the 
aforementioned naming convention.  

Sun Elevation (P27R28):  

s = 90 – Sun Elevation  

s =    

B1:           

  

B2:           

  

B3:           

  

B4:           

  

B5:           

  

B7:           

     

Step 4: Mosaic Images 
Now that you have completed the preprocessing for all images in both scenes, you will join all the pieces 
together.  First, you will create a Layer Stack of all the images in one scene.  Once you have completed this for 
both scenes, you will mosaic the two files to create one image containing all bands for the entire geographic 
extent of both scenes.     

Part 1: Create a Layer Stack 
Open the first atmospherically corrected images that contain no negative values (P27R27) by selecting Bands 1-
5 and Band 7 from the 2727_AtmCorZero folder.  You can do this by holding down your Ctrl (Control) key and 
selecting each file individually. Click Open.      
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You’ll note that in the Available Bands list, each band loads as a separate image.   Before you open bands from 
the second image, you will create a layer stack of these bands.   

 
From the ENVI Main Menu, select Basic Tools > Layer 
Stacking.  The Layer Stacking Parameters window appears.  
Click Import File and select all the files listed in the Layer 
Stacking Input File window and click OK.      

 

Next, click the Reorder Files button and drag the files into the 
correct order with Band 1 at the top and Band 7 at the bottom of 
the list.  Click OK.               

 

Click the Choose button to navigate to the location you are saving the file, 
create a new folder called LayerStack, and name the file 2727_LayerStack.  
Click Open.  In this case, you will accept all the projection information that 
has been imported from the files.  Select OK.  This will take a couple of 
minutes to create the Layer Stack.  When complete, you will see your new 
data cube in the Available Bands list.  You will notice its different 
appearance.   

Close all files in the Available Bands list and load Bands 1-5 and 7 from the 
atmospherically corrected P27R28 images.  Repeat the same process to create the Layer 
Stack, saving it in the LayerStack folder named 2728_LayerStack.  When you are done, 
load only the two data cubes (layer stacks) into your Available Bands List.    

Part 2: Editing ENVI Headers 
As you will note, it is not very easy to make sense of the information in the Available Bands List.  To clear it 
up, you will edit the file header to change the names of the bands so that they are more meaningful.    

 

From the Main Menu toolbar, select File > Edit ENVI Header.  The Edit Header Input File 
window appears.  Select 2727_LayerStack and click OK.  The Header Info window appears.    
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Note the information that appears here provides the dimensions of your raster image.    

 
Click on the Edit Attributes pull-down menu and select Band Names.  Highlight each of the band 
names in the Edit Band Name Values window and enter the band name, hitting Enter after each 
one.  When you have renamed all bands, click OK.                     

Helpful Hint: An easy way to distinguish the band names if you are confused about which is which is to look at 
the B variable in the Band Math expression contained in the layer name.  This should tell you which band each 
name refers to.      

Repeat this for the other data cube.  When you are finished, your Available Bands List 
will appear as shown here.        

Part 3: Mosaicking the Images 
To create one seamless image of the area from which you will subset the 
watershed, the two images that you have in the available bands list must be 
merged, in a sense.  This is called mosaicking.      

 

From the ENVI Main Menu toolbar select Basic Tools > 
Mosaicking > Georeferenced.  The Map Based Mosaic window 
appears.  Select Import > Import Files and Edit Properties. 
Select both images from the Select Input File column of the 
Mosaic Input Files window and click OK.  
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An Entry window will appear.  Enter the following values: 

o Data Value to Ignore: 0 (this will allow the bottom image to show through 
any pixels that have a 0 data value) 

o Feathering Distance: 0 
o Mosaic Display: RGB 
o Red: 3, Green: 2, Blue: 1 
o Color Balancing: No  

 

Select OK.  Do the same for the next Entry window that appears.  Click 
OK.   

Once the mosaic is complete, it will appear in the mosaic window as such.  

 

Select File > Apply and from the Mosaic Parameters 
window, select Choose, navigate to workspace and create a 
new folder named Mosaic, and save it as L5Mosaic.  The 
information in the parameters window should be:   

Output X Pixel Size: 30 meters 
Output Y Pixel Size: 30 meters 
Resampling: Nearest Neighbor 
Background Value: 0         

This process will take a few minutes to complete.  Once the mosaic has completed, it 
will appear in your Available bands list.  Close the Mosaic window and load an RGB 
composite of the image and explore the image.          

This is a relatively seamless mosaic of two images, 
primarily due to the fact that they were acquired by the 
Landsat 5 satellite just minutes apart from each other and 
are therefore aligned in the same path.  Images that are 
taken on different days tend to have less of a seamless 
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mosaic, but are still products that can be used for data analysis.  

Once you are done exploring, close all files in the Available Bands list.  It’s time to move on!   

Looking Ahead: 
Now that you have created a mosaic of the two images that the watershed extends into, you will subset the 
extent of the watershed.  This will remove all pixels from the mosaicked image that do not reside within the 
boundary of the watershed.   

Step 5: Subsetting the Watershed 
Now that you have created a mosaic of the two Landsat 5 scenes, it is time to 
focus in on the study area.  To do this, you will subset the extent of the watershed 
and remove all pixels outside of that extent.   

Part 1: Importing a Shapefile 

 

From the ENVI Main Menu, select File > Open Image File and 
navigate to the location of your mosaicked data cube from the 
previous exercise.  Load an RGB composite of the image.  You will 
now subset this imagery to remove all areas of the image that are not 
within the extent of the St. Louis River watershed.     

 

From the Display window, select 
Overlay > Vectors.  The Vector Parameter window appears.  Select 
File > Open Vector File.  A Select Vector Filenames browser 
appears.         

 

Navigate to the Wtrshd.shp shapefile that you have been provided, which will be the extent of the 
subset.  You will have to change the File Type to Shapefile (*.shp) in order to find it in your data 
folder.  Select it and click Open.           
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The Import Vector Parameters window will appear.  ENVI will convert the shapefile to 
the .evf native ENVI file format.     

 
Accept all the parameters and select OK.  Your shapefile now appears in 
the Vector Parameters window and you will see the boundary of the 
shapefile overlaid on the mosaicked image in the Scroll window.               

Next, you will create a region of interest (ROI) that will be used to subset the image.    

Part 2: Create an ROI and Subset an Image 

 

From the Vector Parameters window, select File > Export Active 
Layer to ROIs.  You will be prompted to select a conversion 
method.  Click the radio button next to Convert all records of an 
EVF layer to one ROI and select OK.  

 

From the Display window, select Overlay > Region of Interest.  The ROI Tool window appears.   
Highlight the file by clicking in the gray box to the left of it, and select File > Subset Data via 
ROIs and select the mosaicked image file in the Select Input File to Subset via ROIs window and 
click OK.                     
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In the Spatial Subset via ROI Parameters window, do the following: 

o Highlight the EVF file in the Select Input ROIs box 
o Set Mask Pixels Outside of ROI to Yes 
o Click Choose, browse to the image output location (L5Mosaic 

folder) and name the file L5Subset, and select Open.        

Once completed, the L5Subset file will appear in the Available Bands List.  
Load an RGB composite in a new display and explore.  You have now created a 
subset of the St. Louis River watershed that has been converted to values of 
Reflectance.  This image can be used to create a Normalized Difference 
Vegetation Index (NDVI) or a Normalized Difference Wetness Index (NDWI) 
for futher image analysis.     

Answer the following questions by exploring the header information (Main Menu, File > Edit ENVI Header 
> Select file > OK):  
What are the dimensions of the newly subsetted image? 
Samples:___________ 
Lines:____________ 
Bands:__________  

What are the dimensions of the mosaicked image? 
Samples:___________ 
Lines:____________ 
Bands:__________  

Using skills you previously learned, rename the L5Subset bands as shown here.   

Recap the general process that you have undertaken to create the L5Subset image 
from the original Landsat 5 images that you were provided.  Draw out a workflow 
highlighting the general steps.             
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Step 6: Unsupervised Classification 
There are a number of different classification schemes available for data analysis.  Unsupervised classification 
allows the software to produce a series of classes (the number of classes is defined by the user) in which to 
aggregate the pixels in an image into.    

Ensure that you have your L5Classify image open in the Available Bands list.  If you have not done so already, 
you may close all other files that you have open.   

 
From the ENVI Main Menu toolbar, select Classification > Unsupervised > Isodata.  Select the 
L5Classify image from the Classification Input File window and click OK.  Fill in the ISODATA 
Parameters window as shown below.  For the file output, save the classification file in the Classify 
folder and name it L5IsodataClass1.                      

The number of output classes defines the range of different classes that the program will separate the 
pixels into.  These classes will later be combined into a lower number of classes based on similarity of the 
land cover class and the definitions provided.  The Maximum Iterations is essentially the maximum 
number of times the program runs the model before the output classification is determined.  Here we have 
defined it as 30 times.  It may not run that many times, because once the Change Threshold is reached, the 
run is complete.  The Change Threshold will determine how much change there is in the number of pixels 
in each class.  If there is less than 2% change in the number of pixels per class, the classification is 
complete.    

The Minimum # Pixel in Class specifies the minimum number of pixels in the smallest class.  For this 
scene, the dimensions are roughly 4400 x 4400, which equates to approximately 19,360,000 pixels in this 
scene.  One thousand pixels produced a decent output.  The Maximum Class Stdv refers to the standard 
deviation.  This number must be much smaller than 1 as the adjusted values of the scene you are working 
with are very small numbers (see band statistics).  The Minimum Class Distance refers to the distance of 
the values in Euclidean space, and should be small to ensure better distinction between classes.  The 
Maximum # Merge Pairs refers to the maximum number of classes to merge.  You are encouraged to 
experiment with these numbers.  
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This process will take some time (1.5 hours or more), and may be a good step to perform during overnight.  A 
progress bar will appear to show you the step of the process that the program is currently in, and how far along 
it has come.      

Once completed, the new image file will appear in your available bands list.  
Load the image (gray scale) into a display window.  You will see that a number 
of classes (represented by the different colors of pixels) have been established.  
You will be combining these classes in the next step.  Open an RGB composite 
of the L5Classify image in a New Display and link the images.  Explore!   

Helpful Hint: Please note that the color selection may vary, thus different 
outputs will likely have different variations in color schemes.                         

Upon inspection, you should be able to immediately note features based on a unique color in the classified 
image.  For instance, here you see royal blue pixels correspond to lakes in the RGB composite.  The default 
coloration happened to use a blue color for water-indicating pixels, and blue may not be the color that you see 
in your image.  

What other relationships can you distinguish between the two images you have loaded?     
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Step 7: Post Classification 
Part 1: Class Color Mapping 
Before you begin combining classes, it is a good idea to know what classes you are working with.  Rather than 
having a list of Class 1, Class 2, Class 3, etc., you will define the classes to make it easier to combine them 
accurately.    

 
Load the classified L5IsodataClass1 image into a display window.  From the display window of the 
classified image, select Tools > Color Mapping > Class Color Mapping.  The Class Color Mapping 
window appears.  Load a 4-3-2 band combination of the unclassified image file into a second display 
window and link the two images.  This band combination is very effective in distinguishing between 
vegetation and non land covers in your image.    

Helpful Hint: You may want to change the band combination of your unclassified image periodically through 
this process to help you distinguish between different features and land covers, or load another band 
combination in another display window.  

Here’s an example of a display line up that you may want to consider [left to right: classified image, true color 
(3-2-1), and false color (4-3-2)]:                                  
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In order to determine which class a particular color corresponds with, you will need to have your Cursor Value 
tool open.  Select Tools > Cursor Location/Value to launch this tool.  As you move your cursor over the 
image, you will note the changing values in the window.  Use these to determine the class that you are going to 
define (name) and change color for.                     

Water is always a good class to start with.  Once you determine that the pixel corresponds to water, click on the 
respective class listed in the Cursor Location/Value window from the Selected Classes list of the Class Color 
Mapping window and change the class name to match the land cover.  In this case, it would be simply Water.  
This would correspond to subclass 11 of the NLCD.  It is a good idea to change the color as well to match your 
perception of the class.  As you work through the classes, your classified image will become more and more 
similar to true color images.  Your color limitations will prevent you from achieving a true color simulation, 
however.  

Continue exploring the image and indicating the land cover from the unclassified image until all the classes 
have been accounted for.   

Helpful Hint: For beginning land cover classification, you may want to start with land cover classes such as 
water, forest, grassland, barren, developed, etc.  For more advanced classification, see the Classification 
Scheme provided by the National Land Cover Dataset provided as an appendix to this tutorial.               
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Once you have finished assigning land covers to all your classes, you can save your changes and proceed to the 
next step where you will be combining the classes together.  Your image will look something like this.  From 
the Class Color Mapping window, select Options > Save Changes.                  

Part 2: Combining Classified Image Classes 
Next you will combine like classes to create generalized classes for the output land cover classification file.  
Numerous classes may have been created based on slight variations in pixel values, even though they are of the 
same general class of land cover.  For instance, you may be interested in combining all urban land cover that 
you identified (roads, towns, etc.) into one urban class.  However, concrete and asphalt reflect differently, thus 
rendering different pixel values.           

 

From the ENVI Main Menu toolbar, select 
Classification > Post Classification > Combine 
Classes.  Select the L5IsodataClass1 image from 
the Select Input File list of the Combine Classes 
Input File window and click OK.          
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The Combine Classes Parameters window appears.  You will be selecting the input classes from the Select Input 
Class list, and matching them to ONE of the classes listed in the Output Class list.  In other words, if you have 4 
Water classes, you will select all four individually from the Input list and match them to only ONE of the Water 
classes in the Output list.  That will allow you to aggregate the similar classes into one.     

Helpful Hint: Match all categories in left-hand box to one category in 
right-hand box.  Make sure to match all like categories to ONLY ONE of 
the categories in the right-hand box.           

Once you have completed matching the classes, click OK.  The Combine Classes Output window appears.             

Select Yes to Remove Empty Classes.  Navigate to the save location and enter the following file name including 
extention: L5Classified.dat.  This assigns a file type to your final file for interoperability purposes with ESRI 
ArcGIS software.  Click OK.  

When you have finished, close all display windows and exit from ENVI.  You will now create your final map 
product.      
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Step 8: Final Map 
Open ArcMap.  Add the L5Classified.dat image to a new map document.  From there, create a final map that 
shows the location of the watershed within the state, all appropriate map elements, and the classes included on a 
map within the legend.     

Simple Sample:                          

Add in additional textual information regarding the processes were involved with the creation of your final 
product.  A great deal of effort went into creating this dataset, and it is time for you to be proud of your hard 
work!  Document it on your final map.  

You have now completed the workflow outlined in this tutorial to create a land cover classification of the St. 
Louis River Watershed.  Outline your workflow (a good item to include on your map) and complete the 
reflection sheet provided. 
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