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Overview 
 
Yellowstone National Park, located in the northwest corner of Wyoming and slivers of southwest 
Montana and eastern Idaho, is the world’s foremost location for hydrothermal activity.  
Comprising of over 10,000 individual features such as hot springs, hot pools, mud pots, 
fumaroles and geysers, the Park attracts millions of visitors each year.  What is the driving force 
behind this concentration of hydrothermal features?  Yellowstone National Park is located on top 
of what is known as a “hot spot.”  From a geologic perspective, this is an area of deep-seated 
magma that is being brought close to the surface through a conduit known as a magma plume; the 
magma then pools in an area nearer to the surface in what is referred to as a magma chamber.  
The hot spot remains stationary as the lithospheric (tectonic) plates move above.  Currently, the 



North American plate is in a position over this hot spot that has Yellowstone perched directly 
above.  
 
Our study area focuses mainly on and around the caldera—or crater area left behind by the most 
recent eruption.  This is where the concentration of hydrothermal features is located within the 
Park.  The objective of this exercise is to see if we can employ remote sensing and GIS to detect 
and map surface heat temperature change in the Yellowstone area.  Detection of surface 
temperatures can provide information that allows Park officials to keep visitors safe as well as 
distinguish areas where increased subsurface geothermal activity may be migrating. 
 
Real-world data and spatial analyzing methods and tools will be used to complete this exercise.  
Remote sensing data derived from Landsat sensors will be used.  Thermal bands from the selected 
sensor(s) will be used to examine heat emissivity between two different time periods.  Using the 
remote sensing software ENVI, you will convert the scaled radiance data received from the 
thermal imagery to display in degrees Celsius in order to draw comparisons between the different 
timeframes of each image.  To further help in the analysis you will create a GIS project using 
Yellowstone data to: map Park boundaries, delineate the most recent caldera, identify 
hydrothermal features, and to determine land elevations.  A hillshade derived from a Digital 
Elevation Model (DEM) and topographic maps in raster format of the area will also be used in the 
display to help provide spatial relationships.  As an optional part of the exercise, the data can be 
opened in ArcGlobe to give a 3D perspective of the study area.  Radar imagery (InSAR) and GPS 
data from inside and adjacent to the caldera may be added to the map to correlate ground 
deformation.  The final output will have the remote sensing imagery, GIS vector data, and the 
DEM with hillshade layered together for each map. 
 
This exercise is designed for educational use only and should not be used to determine 
geothermal, hydrothermal, or magmatic migration; or furthermore, be used as a predictor for new 
hydrothermal feature activity or volcanism. 
 
 

Part 1 – Finding and Downloading Landsat Data for Yellowstone 
National Park   

 
The first thing we need to do is locate remotely sensed, satellite data, either through the internet, 
or stored on a shared network drive.  Ideally, we would like to work with Landsat-7 data and use 
nighttime scenes so as to limit as much thermal atmospheric interference as possible.  Night 
scenes are not commonly available, but they can be obtained through contact with the USGS 
Landsat Project.  However, to become familiar with the procedures involved in obtaining Landsat 
data over the internet, this part of the exercise will take you through the steps of finding and 
downloading Landsat data.  We will go ahead and work with this data throughout the exercises. 
 
 
Step 1:  Access the GLOVIS website and locate Landsat data for Yellowstone Area 
 
In this step we will go to an internet source for browsing and downloading satellite data.  We are 
particularly interested in Landsat scenes that include the Yellowstone National Park area. 
 

 Open up a web browser on the computer (must have internet connection). 
 

 Go to the USGS Global Visualization Viewer website (http://glovis.usgs.gov).  



 
This is the USGS Global Visualization Viewer website created and maintained by the Earth 
Resources Observation and Science Center (EROS).  From this site you can browse a collection 
of satellite images from around the globe.   
 

 From the interactive map, position your cursor over the Yellowstone area (northwest 
corner of Wyoming).  The latitude and longitude coordinates should be close to the 
following:  Latitude: 44.8   Longitude: -110.8 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Landsat scenes are organized according to the Worldwide Reference System. Each scene location 
is given a Path and Row number (for more information you can visit 
http://landsat.gsfc.nasa.gov/about/wrs.html).  
 

 In the Path/Row box set the Path to 38 and Row to 29 (if not already set to these 
numbers) and click Go.   

 

 



 
 From the top menu click on Collection>Landsat MRLC Collections>MRLC/MTBS 

Radiance. 

 
Within this collection there are Landsat 5 scenes which are already converted to radiance values. 
You should end up with a view on your computer screen similar to the one below.  The 
Yellowstone Landsat scene will be highlighted with a yellow border in the display window and 
some brief scene information will be given on the left-hand side.   
 

 
 



Step 2: Browse to find cloud free and date specific scenes   
 
Now that you have accessed the Landsat data collection you want, you will browse through the 
available scenes to find the ones that are best suited for your study.  Cloud free scenes are always 
going to be a good choice.  You are also looking for scenes that have a fairly broad temporal 
range (i.e., 5, 10, or 20 year span).  We want to be able to detect surface heat emissivity through 
time, so we want scenes that are far apart in time. 
 

 Using the Prev Scene and Next Scene buttons, scroll through the Yellowstone scenes 
and notice how the scenes in the display window change.  These are all of the same 
geographic area, just on different dates and with different atmospheric conditions (i.e., 
clouds).  

 
Note: The up and down and side to side arrow keys will change your path or row rather 
than the scene for your location. 
 

 Now, use the dropdown menus for the month and year to locate different scenes. 
 

 Click Go each time you make a selection for month and year. 
 

Note: There may not always be a scene available for the month and year you choose.  
The query will default to the next available month in this case.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notice that as you browse through scenes there is a dynamic link to information about each scene 
to the left of the display window.  This gives information about scene such as its ID, cloud cover, 
and the specific day in which is was acquired.  We will look at more scene information when we 
look at metadata in the following step.  

 
 Right-click on the display anywhere within the highlighted scene that you have browsed 

to (it doesn’t matter which scene you have selected). 
 

 Click Show Metadata to open the metadata dialog window. 



 

 
 Scroll up and down to see what is included in the metadata for this scene. 

 
The metadata dialog gives you more information about the scene such as dataset type, projection, 
datum, terrain corrections, etc.). 
 

 Close the metadata dialog window. 
 

 Right-click the scene again and click on Show Browse. 
 
Show Browse opens up a larger view of the scene you have selected in order to see it more 
clearly.  You can save this image as a JPEG file, but that will not yield the data in which you 
want to analyze.  To get the full, uncompressed dataset, we will have to download the data itself.  
You will do this in a following step. 
 
Other information to notice when browsing through these scenes is if it is available for download 
or not.  The entire Landsat archive has been made available for free.  If a scene is available for 
download, there will be a tag in the upper left-hand corner of the display window that says:  
 
If there is no “Downloadable” tag, that means you need to order the data. There is no charge to 
order data, but it will take about a week for ordered data to be processed and posted on-line for 
you to download. 
 
Step 3:  Download two scenes to be used for analysis and save to disk 
 
Finally, you will select two scenes to download to your computer that can then be used for 
analysis using image analysis software.  You can choose any two scenes out of this collection to 



use for your analysis.  Just remember to keep in mind the atmospheric condition (i.e., clouds), the 
time of year, and the temporal difference between the two scenes as you make your selections.  
  

 Browse to a scene for your first selection (we are using June 1988 for this example). 
 

 Once you are at your scene, click on the Add button at the bottom left-hand of the 
window. 

 
This will add your scene to the list for download. 
 

 Browse to your second scene (we are using June 2007 for this example). 
 

 Click the Add button to add this scene to the list for download. 
 

 Click the Download button. 
 
You will get a message similar to the one below.  These are very large data sets and may require a 
few hours to download, depending on volume of requests and internet speed.  You may also be 
prompted to only load one scene at a time due to the 
large volume of requests and downloads.   
 

 Click Yes to begin the download process 
 
You will then be prompted to fill out a registration 
form in order to complete the download.  This is just 
information feedback to the USGS to use for 
statistical tracking of how and where these data sets 
are being used. 
 

 Complete the registration form using 
education as the primary use of the 
downloaded data. 

 



 When you have finished the registration form and have access to download, proceed 
through the downloading process. 
Note: You may have to disable the Pop-Up blocker on your computer before you can 
begin to download.  Also, you may have to click in the light orange banner at the top of 
the download window and then click “download file” to begin the process. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Save your files to the C:\Student\RS_Class folder (or other location indicated by your 
instructor). 

 
 

Step 4: Unzip downloaded data files in preparation for image analysis software  
 
The Landsat scenes with all their accompanying data have been downloaded to your computer in 
zip files.  You will need to unzip these files in order for them to be used in the image analysis 
software, ENVI.   
 

 Navigate to your C:\Student\RS_Class folder and locate the two files you just 
downloaded (they have a .tar file extension, i.e., NZT050380290604198800.tar). 

 
 Double-click on one of the zip files to open WinZip. 

 
 Select Open the archive using the Classic Interface and click Ok. 

 
 Hold down the shift key 

and click on the first 
file on the interface and 
then the last file to 
select them all. 

 
 Click Extract. 

 
 In the Extract to dialog 

box, navigate to your 
C:\Student\RS_Class 
folder. 

 
 Click Extract. 



 
 
 

 Repeat the above process for the other Landsat tar file. 
 

 When you are finished, close WinZip. 
 
You are now ready to open your newly downloaded and extracted data into the image analysis 
software, ENVI.   
 
 
 

Part 2 – Load and Open Landsat Scenes in ENVI 4.5 
 

In this part of the exercise you will bring your Landsat scenes downloaded in Part 1 into ENVI to 
begin analysis of the data.  ENVI is a highly recognized image analysis software that has the 
ability to quickly, easily, and accurately extract and analyze information from geospatial imagery.  
The steps outlined in this part can be referred back to when opening any subsequent Landsat 
scenes downloaded from GLOVIS. 
 
Step 1:  Launch ENVI and open your two Landsat scenes 
 
In this step, we will open the Landsat files in ENVI in preparation for display and analysis.  Since 
our focus is on surface heat emissivity, information gathered by Landsat’s thermal band will be of 
greatest importance.  We will also need to conduct some atmospheric corrections before making 
sense of the thermal data, but we will get to that later. 

 Open ENVI by double-clicking on the shortcut icon      on your desktop or by 
going to Start > All Programs > ENVI 4.5 > ENVI.  

 
 From the ENVI main menu click File > Open External File > Landsat > NLAPS. 

 



 Navigate to your C:\Student\RS_Class folder and click on one of your extracted data 
sets ( i.e., LT5038029008815610.H1). 

 
 Click Open. 

 
 Repeat the above steps for your second file. 

 
You should have an Available Bands window open that is similar to the graphic below (ID 
numbers may vary depending on what scenes you downloaded). 

 
 
In the Available Bands list, notice the different spectral bands listed for each scene you loaded.  
You will be working with Band 6 or the thermal infrared band. 
 
 
Step 2:  Display images and investigate images loading different bands 
 
Now you are ready to load bands (particularly looking at band 6 – the thermal band) and display 
them in ENVI.  This step will take you through methods of loading different bands and how they 
can be displayed, linked and investigated for further analysis later. 
 

 In the Available Bands List window, click on the “Gray Scale” radio button. 
 

 Select Band 6 from one of the two Landsat files you have loaded. 
 



 Click Load Band. 
 
A Display, Scroll and Zoom window appear.   
  

 
 

 Click and drag the red box in the Scroll window to pan around in the full resolution 
view of the Display window. 

 
 Click on the red (+) and (-) signs in the Zoom window to zoom in and out of the 

display. 



Notice how the red box in the Display window gets larger and smaller.  The box indicates the 
area into which you are zoomed.  If you keep zooming in, you can get down to the pixel 
resolution in the Zoom window. 

 
 

Now you will load the same band for the second Landsat scene in a second display. 
 

 In the Available Bands List window, select Band 6 from the Landsat file that you did not 
choose above. 

 
 Leave Gray Scale selected. 

 
 Click on Display #1 and then New Display.  

 
 
 
 
A blank window will appear entitled #2 Image at the top. 
 

 Click Load Band. 
 
Now you should have a Display, Scroll and Zoom window for both Landsat files with Band 6 
loaded in each. You can move and resize each of these windows to suite your preference.  By 
default, the Display window is larger and at the top, and the Scroll and Zoom windows are 
smaller and at the bottom.  
 
 
 
 
 
 
 
 



 
 
 
Step 3:  Explore the ENVI header files and rename Band 6 
 
Here you will see how to look at other information about each image you have loaded.  Metadata 
stored “behind the scenes” can be accessed through the header file for each image, and 
information such as lat./lon., pixel location, band wavelength, etc. can be found here.   
 

 In the Available Bands List window, click on the (+) sign next to Map Info for one of the 
images. 

 
 Look at the Map Info for the other image. 

 
What is listed here? 
 
 

 From the ENVI Main Menu bar, select File > Edit ENVI Header.” 
 

 In the Edit Header Input window, select one of your images and then click OK. 
 



 In the Header Info window, select Edit Attributes > Map Info. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You should see the same information in the Edit Map Information window as you saw when you 
opened the Map Info within the Available Bands List window.  The difference is that you have 
the option of editing here.   
 

 Click Cancel in the Edit Map Information window. 
 

 Click Edit Attributes > Geographic Corners to open this window. 
 
 
 
 
 
 
 
 



 
 
What is the information in this window telling you?   
 
 

 Click Cancel on the Geographic Corners window. 
 

 Click Edit Attributes > Band Names. 
 

 In the Edit Band Name values window, select Band 6 then type Thermal Band 
<year> (use the year for the image you are editing) in the white space beneath Edit 
Selected Item: 

 



 Click OK in the Edit Band Name values window. 
 

 Click OK in the Header Info window. 
 
Notice what happens in the Available Bands List window. 
 

 Repeat the above process for the other image, renaming Band 6 to Thermal Band 
<year>.   

 
When you are finished, you should have an Available Bands List window that looks similar to the 
one below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step 4:  Link displays and preview pixel values, pixel locations, and measure 
distance 
 
Now that you have your images loaded in ENVI, you can link multiple displays to conduct 
further analyses between them.  This allows you to compare the exact same spatial location in one 
or more images without having to guess at how close your two values are.  Once linked, you can 
compare pixel values, pixel location and measure distances. 
 

 Load both Thermal Bands into display. 
 

 From one of the display windows, click on Tools > Link > Link Displays. 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Link window, make sure Display #1 and Display #2 say Yes. 
 

 Click OK. 
 

 Click and drag the red box around in the 
Display window (you can also move it 
around in the scroll window). 

 
What do you notice between the two displays? 
 
 
 

 Click an area outside the red box in one of 
the Display windows. 

 
This toggles you between the two images you have linked so you have a dynamic view of the two 
different scenes with the click of the mouse.  And, because they are linked, you are seeing the 
exact same location when you toggle back and forth.   
 

 Right-click in one of the display windows and select Cursor/Location Value… (this can 
also be done by selecting Tools > Cursor/Location Value…). 

 
This opens the Cursor Location / Value window which displays data for the location in which 
your cursor is located.   



 

 
 

 Move your cursor around each display and note the 
information inside the Cursor Location / Value window. 

 
What information is given in the window? 
 
 
 

 Close the Cursor Location / Value window. 
 

 Right-click in one of the displays and select 
Pixel Locator…  

 
 In the Pixel Locator window, use the arrow 

button  to toggle between Geographic 
(Lat./Lon.) and Projected Coordinates.  

 
 Use the horizontal and vertical arrow keys 

 move around in the display. 
 
Notice how your position in each display moves and 
the coordinates change in the Pixel Locator window. 
 

 Toggle to Geographic Coordinates (the one 
with Lat and Lon coordinate input lines). 

 



 Click on the decimal degree button DDEG.   
 

 For Lat type in 44.4604.  
 

 For Lon type in -110.8281. 
 

 Click Apply. 
 
Can you determine where this is in Yellowstone? 
Hint: famous feature 
 
 
 
 

 Close the Pixel Locator window. 
 

 From the Display window, click Tools > Measurement 
Tool… 

 
 In the Display Measurement Tool window, select which 

display you want to measure (1 or 2), click the radio 
button next to the window from which you want to 
measure (Image, Scroll, Zoom). 

 
 Click on Units > Km to set the units to kilometers.  

 
 

 

 
 

 Pan to Yellowstone Lake and measure the north – south distance of the West Thumb 
(click on a point to start your measurement then click again at your ending point). 

 
 Right-click to finish your measurement. 

 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once you have your measurement you can change units again to whatever you desire.  You can 
also measure paths by clicking multiple times along your desired path of measurement.  If you 
want to calculate areas, click on Area > Units2 or Acres or Hectares. 
 

 Play around with the Measurement Tool changing units, measuring paths and calculating 
areas. 

 
 Close the Display Measurement Tool window when you are finished. 

 
 
Step 5:  Save your work as ENVI files 
 
Now that you have opened satellite data in ENVI and edited some header files, you will want to 
save these files to be opened in ENVI later. 
 

 From the Main Menu, click on File > Save File As > ENVI Standard. 
 

 In the New File Builder window click Import File… 
 

 Click on one of the two files that are displayed in the Create New File Input File window 
and click OK. 

 

 In the New File Builder window click the  button and then navigate to your  
C:\Student\RS_Class folder. 

 
 For File name type in Yellowstone Thermal <year> (type in the year of your image). 



 Click Open in the Output Filename window. 
 

 Click OK in the New File Builder window. 
 

 Repeat this step again but for your second file that is loaded in ENVI.   
 
When you are finished saving you should have four files (two for each image) saved in your 
workspace for this class. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 If you are going to stop here, continue on with the next step.  If you want to continue on, 
go to Part 3.  

 
 
 
Step 6:  Terminate ENVI session 

 
 Go to the Main Menu and click File > Exit. 

 
 Click Yes when asked if you want to terminate this ENVI session. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



Part 3 – Georeference Using Image-to-Image Registration 
 

The images we are using in comparison may need to be georeferenced to one another.  To do this 
you will use ENVI to complete an image-to-image registration where you use the most desired 
image as your base image and the other image as a warp image.  Be careful selecting Ground 
Control Points (GCPs) which you will use to spatially link the two images.  This will ensure that 
any further analysis will be geographically accurate. 
 
 
Step 1:  Open ENVI files saved previously 
 
If you closed your ENVI session after the last part, complete this step on how to bring that file 
back into ENVI and start another session.  If you still have your ENVI session open from the last 
part, you can continue to the next step.   
 
Note: It might be a good idea to go through this step if you are not sure on how to open saved 
ENVI files once you have exited a session.  

 Open ENVI by double-clicking on the shortcut icon      on your desktop or by 
going to Start > All Programs > ENVI 4.5 > ENVI 

 
 From the Main Menu, select File > Open Image File. 

 
 Navigate to your C:/Student/RS_Class folder and click on one of your 

Yellowstone Thermal files. 
 

 Click Open. 
 

 Repeat this step for the other Yellowstone Thermal file. 
 

Note: There are two files for each image you have saved in ENVI format.  One is a 
header file (.hdr), and the other is the native ENVI file.  You can open either of these to 
bring the file into ENVI as long as they are both located in the same folder. 
 

 
 
You should now have both files, with the changes you made previously, open in the Available 
Bands List window within ENVI.   
 



Step 2:  Perform an Image-to-Image registration 
 
In order to make sure we are analyzing two (or more) images that are in the same spatial extent, 
we need to register the images so that they line up as closely as possible.  We can do this in ENVI 
by taking the image that we want as our standard (base image) and aligning the second image 
(warp image) to it.   
 
Rules of thumb for which image should be a base image when using Landsat: 

1. A terrain corrected Landsat 7 image 
2. A terrain corrected Landsat 5 or Landsat 4 image 
3. A non-terrain corrected Landsat 7 image 

 
*Note: The free, general “Landsat Archive” data now come orthorectified using the same GCPs.  
This step may not be necessary, but it is a good exercise to know the steps involved for 
performing an image to image rectification.  
 
We are using all terrain corrected Landsat 5 images.  In theory, we should not need to register 
them.  However, it is highly recommended that a registration be performed to ensure proper 
alignment.  So, in this case, it does not matter which image is the base and which is the warp.  We 
will make the most recent image as the base for this exercise (2007 for this example). 
 

 Load the Thermal Band for your most recent image into Display #1.  This will be your 
base image. 

 
 Load the Thermal Band for your other image into Display #2.  This will be your warp 

image. 
 
Next, we need to find the dimensions of our base image so when we do the registration we will 
have those dimensions to input for our warp image.   
 

 From the Main Menu, select File > Edit ENVI Header. 
 

 In the Edit Header Input File window, select your base image (the most recent image). 
 

 Under File Information, make note of the dimensions (i.e., Dims:  8412 x 7848 x 7).   
 
What are the numbers for your dimensions if not the same as the example?   
 
You will need to refer to these numbers later on in the registration process below. 
 

 From  the Main Menu, select Map > Registration > Select GCPs: Image to Image 



 In the Image to Image Registration window, 
select Display #1 (most recent image) for your 
Base Image and Display #2 (your older image) 
for your Warp Image.  

 
 Click OK. 

 
 In the Ground Control Points Selection window, 

click Show List. 
 
This will bring up an Image to Image GCP List window.  
This is where your ground control points will be 
displayed as you pick them, along with each RMS error 
value. 
 
To start, you will locate an easily identifiable location on both images.  This may be a little 
difficult as there are no human made features that are easy to pick out.  Your best bet will be to 
select distinct feature around the lake (i.e., corners, edges, protruding inlets or juts of land). 
 

 In the Zoom window, place the red cross hairs at the same place on both images.  It may 
be easier to move the red box around in the Display window first and then fine-tune your 
selections in the Zoom window. 

 
Note:  Be sure you have unlinked your displays if they are still linked from a previous step. 
 

 Once you find two similar points on each image, click Add Point in the Ground Control 
Points Selection window. 
 

 In the Image to Image GCP List window, click File > Save Table to ASCII. 
 

 Navigate to your C:/Student/RS_Class folder and name the file. 
 
You will do this after every set of control points you add. 
 

 Go back to your images and select a second set of control points and click Add Point in 
the Ground Control Points Selection window.   

 
Continue this procedure until you have at least five control points.  Your GCPs should be spread 
around your image.  Once you have five or more points, an RMS error value will be calculated 
and will be displayed in the Image to Image GCP List window (you may have to scroll to the 
right to see these values).  RMS is in pixels.  You can delete any points that have a high RMS 
value. 



 
 When you are satisfied with your GCPs, in the Ground Control Points Selection window, 

click Options > Warp File. 
 

 Select your warp file (oldest image in this case) from the Input Warp Image window and 
click OK. 

 

 
 

 In the Registration Parameters window, input the following: 
 
Method: Polynomial 
Degree: 1 
Resampling: Nearest Neighbor 
Background: 0 
Upper Left X: 1  
Upper Left Y: 1 

 
 For Output Samples and Output Lines, refer back to the dimension numbers you looked 

up from your base image earlier in this step.  Input the first two numbers in the Samples 
and Lines Output (in this example the numbers are: 8412 x 7848). 

 
 Click Choose to enter an Output Filename.  Save it to your C:/Student/RS_Class folder. 

 



Your Registration Parameters window should look like the example below.  If you are using 
different images than are being used in this example, your Output Samples and Output Lines 
numbers may be somewhat different. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Click OK. 
 
The registering process may run for several minutes before it 
is successfully complete.  Once the registering process is 
complete, the newly registered file loads into your Available 
Bands List window. 
 

 Close the Image to Image GCP List window (save 
your GCPs if you have not done so already).   

 
 Load your newly created warp thermal band into the 

Display #2. 
 

 Link the images, Tools > Link > Link Displays… 
 
Your images are now geo-registered together. 
 

 Exit ENVI or move on to the next part. 



Part 4 – Atmospheric Correction of Thermal Band 
 
Due to thermal atmospheric interference, data received at the satellite will not be a true surface 
emission value.  To correct for this interference, some sort of correction methodology should be 
employed to get more accurate surface emissivity data.  There is, at this time, many different 
methodologies that focus on this type of correction with no one standing out as the best for all 
scenarios. The research shows that some type of correction should be used and even if the 
coefficients are not completely correct, that is better than no correction at all. For this part of the 
project, you will use ENVI to run atmospheric coefficients in order to depict a better at-surface 
thermal value to work with.  Then, you will convert these corrected radiance values to 
temperature. 
 
 
Step 1:  Open your geo-registered scenes in ENVI 
 
If you have ENVI open from the previous part, move on to step 2.  If you ended your ENVI 
session at the end of the last part, complete this step to open your co-registered scenes.  

 Open ENVI by double-clicking on the shortcut icon      on your desktop or by 
going to Start > All Programs > ENVI 4.5 > ENVI 

 
 From the Main Menu, select File > Open Image File. 

 
 Navigate to your C:/Student/RS_Class folder and click on your Yellowstone Thermal 

file with the most recent date (Yellowstone Thermal 2007 in this example). 
 

 Click Open. 
 

 Repeat this step to open your newly created warp file (Yellowstone Thermal 1988_warp 
in this example). 

 
 Load each scene’s thermal band into a display in ENVI. 

 
 
Step 2:  Use online atmospheric Correction Parameter Calculator 
 
An atmospheric correction tool has been developed and made available through the web by a 
team of Landsat scientists.  We will use this tool to correct our Landsat images before moving on 
further into the analysis.  The one problem we face with using this calculator is that it only has 
data back to March 1, 2000.  Therefore, to correct scenes earlier than this, the calculator will not 
work.  In this example, we are using scenes from 1988 and 2007.  We will use the online 
calculator to correct the 2007 scene and then, just for the purposes of this exercise, we will use 
the same parameters to correct for the earlier scene.  Since the scenes are from the same time of 
year, we will just assume a similar atmospheric condition.  
 

 Open a web browser and go to the following address:  http://atmcorr.gsfc.nasa.gov/.  
 
This brings up the Atmospheric Correction Parameter Calculator.  Within the calculator window 
there are fields to fill in before the correction can be performed.  You will need to open your 



image in ENVI to find the information that needs to be entered into the calculator.  You can also 
get this information from viewing your scenes on the GLOVIS site where you originally 
downloaded the files.   
 

 Using information from your selected scene in ENVI, enter the following information 
into the Atmospheric Correction Parameter Calculator: 

 
In the example below, the June 25, 2007 Landsat scene is being used.  1:00 p.m. MDT was used 
which makes GMT 19:00.  Latitude and longitude can be found by using your pixel locator 
(Tools > Pixel Locator).  In this example a location was selected near the center of the scene.  
Make sure to select Landsat-5 Band 6.  Enter your e-mail address at the bottom so you will 
receive a copy of the calculated results.  The rest of the parameters in the calculator should be the 
same as the example below. 

 
 Click Calculate. 

 
You will get a message that says this calculation may take a while. 
 



 Click OK. 
 
After a few minutes, a screen will pop up with the results of your calculation and will look 
something like the example below.  You will also get an e-mail with these same results. 
 

 
 
 
Step 3:  Use ENVI to convert TOA radiance to surface radiance 
 
In this step you will use the Band Math tool in ENVI to convert the at sensor (top of atmosphere) 
radiance values to surface radiance values.  Using the values obtained from the online calculator 
in the step above and some average surface emissivity values, you will produce an image that 
displays more realistic ground radiance values.   
 

 From the Main Menu, select Basic Tools > Band Math. 
 
A Band Math window appears.  Here is where you will create an expression to convert the values 
from your images to correct for atmospheric disturbances.  The equation we will use is as 
follows: 
   LT = LTOA / (τε + Lu + (1 - ε) Ld) 
 
 



Where: 
 
 LT = Surface radiance (what we are converting to) 
 
 LTOA = At sensor radiance or top of atmosphere radiance 
 
 τ = Atmospheric Transmission (obtained from the online calculator in previous step) 
 

ε = Surface Emissivity (obtained from NASA JPL Spectral Library 
http://speclib.jpl.nasa.gov/)  

 
Lu = Upwelling Atmospheric radiance (obtained from the online calculator in previous 
step) 

 
Ld = Downwelling Atmospheric radiance (obtained from the online calculator in 
previous step) 

 
 In the Band Math window, type in the expression as shown in the graphic below.   

 
Note:  The values shown below were derived from the online calculator for the June 2007 
Landsat scene.  The emissivity value was obtained from the NASA JPL spectral library.  B6 in 
the equation is the indicator for which band we are using as the variable in the equation. 

 
 Click Add to List and the expression will be added to the Previous Band Math 

Expressions at the top. 
 

 Click OK. 
 



 In the Variables to Bands Pairings window, click on your thermal band for your most 
recent image (2007 in this example) to highlight it and designate it as the variable in the 
equation. 

 
 Click Choose and navigate to your 

C:\Student\RS_Class.  
 

 Give your new output a name (i.e., 
atm_corr_2007). 

 
 Click OK.  

 
Band Math will run the equation and when it is 
finished your new output will be added to the 
Available Bands List window.   
 

 Load the new output into a display window 
in ENVI. 

 
 Open the Cursor Location / Value window 

(Tools > Cursor Location / Value…). 
 

 Link the new output display with the 
uncorrected display (i.e., Yellowstone 
Thermal 2007). 

 
 Move your cursor around one of the 

displays and view the values next to Data: 
for each display. 

 
What do you notice is different between the two 
display values?  
 
 
What have you done to make this change? 
 
 
 

 Repeat the above procedure for your other image (Yellowstone Thermal 1988_warp in 
this example).   

 
Be sure to use your geo-registered image (warp) as the input variable in the equation this time.  
You will leave all other input values the same, unless you are using a second image that is later 
than March 1, 2000.   
 

 After you finish the atmospheric correction for your second image, load it into a display. 
 

 Link your two atmospherically corrected displays and compare the data in the Cursor 
Location / Value window.  

 



The values might not make much sense yet, but you should notice some differences in values at 
selected locations throughout the images.  You are now going to convert these at surface radiance 
values to temperature values in degrees Kelvin.  
 
 
Step 4:  Convert surface radiance values to temperature 
 
Once the pixel values have been converted to surface radiance, you can then use Band Math in 
ENVI to convert the values to temperature.  The previous part of the exercise corrected the 
radiance values for thermal atmospheric interference.  Now these corrected radiance values will 
be converted to temperature in degrees Kelvin.   

 
 From the Main Menu, select Basic Tools > Band Math to open the Band Math window. 

 
The equation for conversion from radiance to temperature is as follows: 
 

T =            K2____ 
ln(K1/Lλ + 1) 

 
Where: 
 
 T = Temperature in degrees Kelvin 
 
 K2 = Calibration constant 2 from Landsat table (see below) 
 
 ln = Logarithm entered as alog in Band Math 
 
 K1 = Calibration constant 1 from Landsat table (see below) 
 

Lλ = Spectral radiance in watts/meter squared *ster* μm (corrected radiance value from 
satellite image) 
 

 
Source: Landsat 7 Science Data Users Handbook 

http://landsathandbook.gsfc.nasa.gov/handbook/handbook_htmls/chapter11/chapter11.html  

 
 In the Band Math window type in the expression as indicated in the below graphic. 

 
 



 Click OK. 
 

 In the Variables to Bands Pairings window, 
highlight your atmospheric corrected band to 
designate it as the variable in the expression. 

 
 Click Choose and navigate to your 

C:\Student\RS_Class folder and name your 
new output (i.e., Temp_corr_2007). 

 
 Click OK. 

 
 
 
 
 
 
 
The Band Math conversion will run and then 
your new output will be added to the 
Available Bands List window.   
 

 Repeat this step for your second 
image. 

 
 Load both temperature converted 

images into displays. 
 

 Use the Cursor Location / Value tool 
to view temperatures around the 
Yellowstone area. 

 
Note:  These temperature values are in 
degrees Kelvin.  To convert these values to 
degrees Celsius, subtract 273.15. 
http://www.allmeasures.com/temperature.html  

 
 (Optional) Create an output for each 

scene where values are converted to 
degrees Celsius. 

 
 

 If you are stopping here, exit ENVI and terminate your session.   
 

 If you are moving on to the next part, leave ENVI open with your new temperature 
converted data sets open. 

 
 



Part 5 – Perform Unsupervised Classification and Export as Vector File 
 

Using the newly converted temperature values, a classification scheme can be set up using the 
ENVI software to show a range of surface temperature values throughout the study area.  This 
data can then be imported into ArcGIS and used in an overlay analysis with other Yellowstone 
data to help determine ground surface temperature change through time. 
 
 
Step 1:  Open the converted data in ENVI 
 
If you have your data open in ENVI from the last part, move on to the next step.  If you exited 
ENVI after the last part, follow this step to open your data and prepare for classification. 

 Open ENVI by double-clicking on the shortcut icon      on your desktop or by 
going to Start > All Programs > ENVI 4.5 > ENVI. 

 
 From the Main Menu, select File > Open Image File. 

 
 Navigate to your C:/Student/RS_Class folder and click on one of your temperature 

corrected files (i.e., Temp_corr_2007). 
 

 Click Open. 
 

 Load the image into a display in ENVI. 
 

 Repeat this step for your other temperature corrected image. 
 
 
Step 2:  Run an unsupervised classification for both data sets   
 
Now we will use the classification tool in ENVI to separate the pixel values into a set of classes.  
This will more readily distinguish areas of different heat intensities for further spatial analysis. 
 

 From the Main Menu, select Classification > Unsupervised > ISODATA. 
 

 
 Select one of your temperature corrected datasets (i.e., Temp_corr_2007). 

 
 
 
 
 



 
 Click OK. 

 
 Fill in the ISODATA Parameters window with the values indicated in the graphic below. 

 
 Click Choose and navigate to your C:\Student\RS_Student folder and give your output a 

name (i.e., Yell_Therm_Class_2007). 
 

 



 Click OK. 
 
The classification process will run (may take a few minutes) and the ISODATA classification 
subset will be added to your Available Bands List.   
 

 Load the ISODATA classification into a new display. 
 

 Link the classification with the temperature converted image from the same year (i.e., 
Yell_Therm_Class_2007 with Temp_corr_2007) and compare the data. 

 
 Repeat this step for your second image. 

 
At the end of this step, you should have four displays on your screen.  A temperature corrected 
image and a classification display from each year you are analyzing.   
 
 
 
Step 3:  “Sieve” and “Clump” your classes as part of the post classification process 
 
To smooth and generalize the classified images, we will run a “sieve” and then a “clump” as post 
classification processes.  A sieve is often run first to remove isolated pixels based on a size 
threshold, then clump is run to add spatial coherency to existing classes by combining adjacent, 
similar classified areas (ENVI tutorial). 
 

 From the Main Menu, select 
Classification > Post Classification 
> Sieve Classes.  

 
 In the Classification Input File 

window, select one of your 
Yellowstone classifications (i.e., 
Yell_Therm_Class_2007). 

 

 
 

 
 Click OK. 

 



 In the Sieve Parameters window, leave all the 
parameters as listed then click Choose and 
navigate to your C:\Student\RS_Class folder and 
name your output (i.e., 
Yell_Therm_Class_Sieve_2007). 

 
 Click OK. 

 
The sieve process will run and the new output will be 
added to the Available Bands List Window. 
 

 From the Main Menu, select Classification > 
Post Classification > Clump Classes. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Classification Input File window, select your “sieved” image from above (i.e., 
Yell_Therm_Class_Sieve_2007).  

 



 In the Clump Parameters window, leave all 
parameters as is and then click Choose and navigate 
to your C:\Student\RS_Class folder and name your 
output (i.e., Yell_Therm_Class_Clump_2007). 

 
 Click OK. 

 
The clump process will run and the new output will be added 
to the Available Bands List window.   
 

 Repeat the “sieve” and “clump” processes in this 
step for your other image. 

 
 Add all your “sieved” and “clumped” outputs into 

displays and compare the results. 
 
 
 
 
When you are finished, you should have four displays open 
in ENVI.  Your displays should look similar to the graphic 
below (views will vary depending on where you have your 
cursor located in each scene). 
 



Step 4:  Name classified categories 
 
In this step you will name your new categories based on a class that each represents.  These will 
all be a range of temperatures in degrees Kelvin.  You can then pick a color scheme to go along 
with these categories.  This naming process will differ between users as it is dependent on how 
the temperature ranges are divided.  
 

 Load your two temperature corrected images (i.e., temp_corr_2007 & temp_corr_1988) 
into the displays currently occupied by your “sieve” outputs. 

 
This will allow you to refer to the actual temperature data in the images as you group your 
classes.  Your ENVI interface should look similar to the graphic below. 
 

 
 Link the displays 

 
 In the display window of one of 

your “clumped” outputs, select 
Tools > Color Mapping > Class 
Color Mapping.  

 
 
 
 
 
 
 



 In the Class Color Mapping window, click 
on the categories under Selected Classes 
and compare the color of each class with 
the temperature data from your thermal 
imagery. 

 
 Open the Cursor Location / Value tool in 

order to see the temperature values from 
the thermal image (Tools > Cursor 
Location / Value). 

 
 Name each class according to the value in 

the corresponding thermal image. 
 
For this example the following categories were 
used:  Cool, Warm, Very Warm, Hot, Very Hot, 
and Extremely Hot.  You can choose different 
names and a different number of categories if you 
would like.  You might give the same name to a 
class.  These will be combined next. 
 

 From the Main Menu, select Classification 
> Post Classification > Combine Classes. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 In the Combine Classes Input File 
window, select your “clumped” file for 
the year you are classifying. 

 
 Select your input and output classes to 

combine (i.e., select all the multiple 
Warms as input and combine them with 
a single Warm for output). 

 
When you are finished you should only have 
one of each category in the Select Input Class 
scroll window (see graphic at right). 
 

 Click Add Combination. 
 

 In the Combine Classes Output window, 
for Remove Empty Classes, select Yes. 

 
 Click Choose and navigate to your 

C:\Student\RS_Class folder and name 
your new output (i.e., 
Yell_Final_Class_1988). 

 
 Click OK. 

 
Your new classification output will be added to 
the Available Bands List.  
 

 Repeat this step for your other image 
using the same classification processes 
and names for classes.   

 
When you are done classifying both images, you 
will have a harmonious classification scheme in 
which to run comparisons on both of your 
Yellowstone scenes.   
 

 Load both of your newly classified images into displays in ENVI. 
 

 Link the two displays and toggle back and forth to view changes from one year to the 
next. 

 
The graphic below is an example of what your two final classified images might look like in a 
side by side comparison.    
 
 
 
 
 
 
 



 
 
 
Step 5:  Transform classifications to vector files to be imported into GIS 
 
Now you will prepare your classified images for use in a geographic information system (GIS).  
Currently, the image files are rasters.  We are going to transform them into vector file format and 
then into shapefiles (a native file format in GIS) for our spatial analysis in the last part of this 
exercise.    
 

 From the Main Menu, select 
Classification > Post 
Classification > Classification 
to Vector. 

 
 In the Raster to Vector window, 

select one of your new 
classified outputs. 

 
 
 
 
 
 
 
 
 
 
 
 
 



 Click OK. 
 

 In the Raster To Vector Parameters window, hold down the Ctrl key and select the 
classes to vectorize (leave unclassified and null unselected).  

 
 Click Choose and navigate to your 

C:\Student\RS_Class folder and give your 
output a name (see example to right). 

 
 Click OK. 

 
A Raster to Vector Conversion window will open 
showing that the process is running.  Also, a Build 
Vector Topology window will open showing its 
process.  Both these windows will open to run the 
respective process for each input class. This 
conversion may take several minutes to complete.  
 
When the process is complete an Available Vectors 
List window will open. 
 

 Select your layer from the Available 
Vectors List window. 

 
 Click Load Selected. 

 
 
 
 
 
 
 
 
 
 
 
 

 In the Load Vectors window, click 
on the display that has your 
classified data for the same year in 
it. 

 
 Click OK. 

 
 



Your new vector data will overlay your classified raster data in the display.  You can then take a 
look around the display to see how the vector data has taken shape.   
 

 In the Vector Parameters window, select File > Export Active Layer to Shapefile. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 In the Output EVF Layer to Shapefile 
window, click Choose and navigate to 
your C:\Student\RS_Class folder and 
give your shapefile a name. 

 
 Click OK. 

 
 Repeat this step for your other 

Yellowstone classification file. 
 
When you are finished, you will have two 
shapefiles saved to your workspace on the C: 
drive.  Take a look at these using windows 
explorer.  For both of your shapefiles created you should have four separate file extensions that 
make up the shapefile - .shp, .dbf, .shx, and .prj. 
 

 Exit ENVI and terminate your session. 
 
 

 
 



Part 6 – Build Project in ArcGIS for Further Spatial Analysis 
 
For this part of the exercise you will use ArcGIS to build a project using your data from the 
previous parts of the exercise along with available vector data for the Yellowstone area.  The data 
includes hydrothermal features, 640,000 year caldera boundary, Park roads, campsites and other 
significant features in the area. 
 
 
Step 1:  Launch ArcMap and add all the data files   
 
You have spent the majority of this exercise working with ENVI to analyze and manipulate 
satellite imagery in which you obtained.  You have converted your raster images to vector files 
and exported them into shapefile format.  Now you will add these to a new ArcMap document, 
along with other Yellowstone data that is available, to conduct further spatial analysis of the 
surface heat emissivity between the two years you have selected. 

 Launch ArcMap by double-clicking on the ArcMap icon  on your desktop or click 
on Start > All Programs > ArcGIS > ArcMap.  

 
 Start using ArcMap with A new empty map. 

 
 Click OK. 

 
Now you need to set the data frame’s spatial reference so that when you bring in data, it all lines 
up correctly. 
 

 In the Table of Contents, right-click on Layers.  This 
is the generic name given to the data frame. 

 
 From the Layers context menu, click Properties.  This 

will open the Data Frame Properties window. 
 

 In the Data Frame Properties window, click the 
Coordinate System tab at the top. 

 
 Under Select a coordinate system: expand the 

Predefined folder (click on the “+” sign), then expand 
the Projected Coordinate Systems folder, the UTM 
folder, and finally the WGS 1984 folder.  

 
 Scroll down and click on WGS 1984 UTM Zone 12N.  

This indicates the projected coordinate system that is 
best suited for the Yellowstone area. 

 
 Click OK.  

 
 
 
 
 



 

 
 

Now that your data frame is set to the appropriate spatial reference, you can begin adding data 
layers to the map.  All data will conform or be projected into the spatial reference you have 
established, so everything should line up correctly.   

 
 Click on the Add Data  button and navigate to the C:\Student\RS_Class folder. 

 
Hint:  You can use the Connect to Folder  button to directly connect to a folder that may be 
buried several levels within a directory.  This will provide you with a direct link to this folder 
each time you need to navigate to it.  
 

 Hold down the Ctrl key and select both of the shapefiles you created in ENVI. 
 



 
 

 Click Add.   
 
A Geographic Coordinate Systems Warning window pops up to tell you that the data you are 
trying to add has a different geographic coordinate system than that of the data frame.  ArcGIS 
will project these on-the-fly so they fit into the coordinate system that is set.  We have done this 
so the rest of the Yellowstone data will fit into this spatial reference as well. 
 

 Click Close on the Geographic Coordinate Systems Warning window. 
 
Your Yellowstone thermal data, in vector, shapefile format, is drawn and displayed on the map.   
 

 Click the Add Data  button. 
 

 Navigate to C:\GisData\Yellowstone\Shapefiles.   
 
Hint:  Use the Connect to Folder  button to set up a direct link to this folder. 
 

 Click on the first shapefile listed called caldera.shp, then while holding down the Shift 
key, click on the last shapefile listed called yell_rivers.shp.  This will select all the 
shapefiles listed. 

 
 
 
 
 
 
 
 



 
 

 
 
 

 Click Add. 
 
A warning will pop up saying there is an unknown spatial reference.  Since we set the data frame 
spatial reference earlier, ArcGIS will project these shapefiles on-the-fly according to the data 
frame.   
 

 Click OK in the Unknown Spatial Reference warning window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



You should have a Table of Contents that has the Yellowstone layers on top of your thermal data, 
and a map in the display area, similar to the previous graphic.  Your display may look a little 
differently based on the default colors that were chosen when you added your data layers.  We 
will change the colors and look of the map later. 
 

 From the tools toolbar, click on the Zoom In  tool. 
 

 Click on the display (area where the map is located) and drag a box around an area to 
zoom into a smaller area.  Hint:  You can also do this by holding down the Shift key and 
using your mouse wheel to zoom in and out. 

 

 From the tools toolbar, click on the Identify   tool. 
 
The Identify window is displayed.  
 

 Click on the largest lake in the display.  
 

 
 
What are the names of the three smaller lakes to the southwest of Yellowstone Lake? 
 
 
 

 Use the other tools on the tools toolbar to explore around in the map display.   
 
 
Step 2:  Symbolize layers in the map  
 
Now you will change the symbology of the layers displayed on the map in order for them to be 
more distinguishable.  We will also display the categories for the thermal data you brought in 
from ENVI. 
 

 From the Table of Contents, uncheck the boxes next to your two Yell_Therm layers.   



This will prevent them from being re-drawn every time you make a change to the map symbology 
and speed up your results.  
 

 From the Table of Contents, click on the line symbol under the caldera layer (click 
directly on the symbol, not the name of the layer. 

 
 In the Symbol Selector window, click on More Symbols and then select Geology 24K. 

 
 Scroll down through the list of symbols and select Geophysical data collection line – 

Accurately located. 
 

 Make Color: Mars Red, Width: 3. 
 

 Click OK. 
 
You have symbolized the 640,000 year old caldera boundary so that it stands out against the rest 
of the data.  You will continue to symbolize the rest of the layers in the map. 
 

 Click on the symbol for yell_rivers. 
 

 In the Symbol Selector window select the symbol for River. 
 

 Leave the default color and make Width: 1.5. 
 

 Click OK. 
 

 Symbolize the thermals and yell_lakes layers on your own.  Be sure to make them stand 
out within your map display.  

 
The graphic below is an example of how your display might look. 
 

 



 Double-click on one of your Yell_Therm layers to open the Layer Properties window. 
 

 Click on the Symbology tab. 
 

 Under Show: click on Categories and then Unique values. 
 

 Click Add All Values and your classes will show up in the window.   
 

 Using the up  and down  arrows, highlight and move the classes into the correct 
ascending order. 

 
 Uncheck the box next to <all other values>. 

 
 In the Color Ramp dropdown menu, select Slope (green going up to red).   

 
Hint:  Right-click in the Color Ramp window and select graphic view to uncheck it so that the 
word description can be viewed. 
 
You should end up with something similar to the graphic below. 

 
 Click OK in the Layer Properties window. 

 
 Turn on your Yell_Therm layer to display it.   

 
Now the classes you set up are displayed on the map.  The map is still a bit cluttered with all 
these values.  We will clean it up later with some more pinpointed analysis. 
 

 Repeat this symbology process for your second Yell_Therm layer and then turn it on.  
 

 After you have both Yell_Therm layers symbolized by category, zoom into different 
areas of the Park, in and around the 640,000 year old caldera boundary.  Toggle (turn on 
and off) between your two Yell_Therm layers and see what you notice.   



Step 3:  Use selection tools to locate hottest areas in and around caldera 
 
Next we will use a select by location and select by attributes to pull out the hottest areas detected 
from our thermal data.  Then we can export the results of that analysis to a new output (shapefile) 
to include in our final map. 
 

 Turn on one of your Yell_Therm layers (check the box next to the layer in the Table of 
Contents). 

 
 From the Main Menu, click Selection > Select By 

Location.   
 

 In the Select By Location window, enter – I want to: 
select features from – Yell_Therm (your choice of 
the two thermal layers) – that: are within a distance 
of – the features in this layer: caldera – set the 
distance at 30 Km. 

 



 Click OK. 
 
Now all the data in your Yell_Therm layer that are within 30 Km of the caldera boundary will be 
selected.  This should capture everything inside the caldera boundary as well.   
 

 From the Main Menu, click Selection > Select By Attributes. 
 

 In the Select By Attributes window, enter – Layer: 
Yell_Therm (your choice of the two thermal layers) – 
Method: Select from current selection – double-click 
on “Class_Name” – click the equals “=” sign – click 
Get Unique Values – double-click ‘Extremely Hot’ 

 
 Your Select By Attributes window should look like the graphic 
below: 

 
 Click OK.   

 



Now you should have all the Extremely Hot ground surface temperatures that are within a 
distance of 30 Km of the caldera selected on your map.   
 

 In the Table of Contents, right-click on your Yell_Therm layer that is part of the 
selection. 

 
 Click Data > Export Data. 

 
 In the Export Data 

window, Export: Selected 
features – Use the same 
coordinate system as: the 
data frame  

 
 For Output shapefile or 

feature class: navigate to 
your 
C:\Student\RS_Class 
folder and name your new 
output (i.e., 
Ext_surf_temp1988) 

 
Note:  Be sure to save it as a 
shapefile and not a geodatabase 
feature class; although either 
would work. 
 
 
 
 

 



 Click OK. 
 

 When asked if you want to add your new feature class as a layer to the map, click Yes. 
 

 Clear your selected features from the Yell_Therm layer (Selection > Clear Selected 
Features).  

 
 Turn off your Yell_Therm layer. 

 
 Change the color of your new output layer so that is shows up against the rest of the data. 

 
 Repeat this step for your second Yell_Therm layer and add it to the map.   

 
When you are finished with this step, you should have a map display that looks similar to the 
graphic below: 
 

 
 
 
 
 



Step 4:  Add raster topographic map and hillshade layer 
 
Finally, you will add a couple more datasets to your map document to give the study area some 
perspective.  First, raster datasets displaying a topographic composite map of the area will be 
added as base map for the location of roads and other Park features.  Then, a hillshade, already 
created using a Digital Elevation Model (DEM) of the area will be placed at the bottom of all the 
data to provide some terrain perspective.  You will have to set the transparencies of some of the 
layers in order to make the final datasets visible.   
 

 Click on the Add Data  button. 
 

 Navigate to the C:\GisData\Yellowstone\Topos folder. 
 

 Select both the ashton.tif and cody.tif files.  

 Click Add. 
 
Raster layers displaying the topographic maps for the Yellowstone area should now be displayed 
on your map.  Be sure that both of these layers are at the bottom of your Table of Contents.  If 
not, you can click and drag them there. 
 

 Right-click on one of your Ext_surf_temp layers that you created and click on Properties 
to open up the Layer Properties window. 

 
 In the Layer Properties window, select 

the Display tab. 
 

 Set the transparency to 35%. 
 

 Click OK. 
 
This will allow the topo map to be seen 
underneath the surface temperature layer. 
 

 Set the transparency for the other 
surface temperature layer the same. 

 
 



 Click the Add Data  button. 
 

 Navigate to the C:\GisData\Yellowstone\DEM folder. 
 

 Click on hillshad_yel2 and click Add. 
 
A hillshade layer showing elevation perspective is added to your Table of Contents.  You want 
this layer to be at the bottom of your list.  Click and drag it to the bottom if it is not already. 
 
 

 Right-click on the ashton.tif layer and click on 
Properties. 

 
 In the Layer Properties window, click on the Display 

tab and set the transparency to 50%. 

 
 Set the transparency for the cody.tif layer to 50% as well.   

 
You now have a display with Yellowstone thermal features, lakes, streams and the 640,000 year 
old caldera boundary; the two different dates showing the most intense ground temperatures; all 
on top of topographic maps of the area and shaded relief.  By turning on and off the surface heat 
layers, you can get an idea of change that has taken place temporally over that time period.   
 

1. How had surface heat migrated over time?   
 

2. Is there a correlation between hydrothermal features (Old Faithful, etc.) to the surface 
heat you have mapped for your two dates? 

 
3. Does elevation seem to play a role?   

 
4. What would be your suggestions for further spatial analysis on this topic?   



 
(Optional) Part 9 – Using ArcGIS Spatial Analyst to View Data in 3D 

 
For the last part of this exercise you will use your data from the previous output and combine it 
with a Digital Elevation Model (DEM) for the project area to create a 3D view of the data.  We 
will also drape radar imagery (InSAR) showing ground deformation, and GPS ground monitoring 
data over our surface in the 3D environment.  Using ArcGlobe, a “fly through” animation can 
then be set up to view the study area and see surface heat emissivity changing over time with a 
topographical perspective. 
 
Step 1:  In ArcMap, add the DEM, InSAR and GPS data to the map. 
 
Step 2:  Turn on Spatial Analyst extension from the Tools menu.  Create Hillshade, Slope and 
Aspect using the DEM data. 
 
Step 3:  Open ArcGlobe and make sure 3D extensions and Animation tools are turned on.  Add 
all your data from your outputs in the previous steps. 
 
Step 4:  Set Base Heights for your datasets based on the DEM data, set up appropriate 
symbology, and set the resolution and hillshade effects for the datasets. 
Step 5:  Practice navigating through the scene, zooming in and out and viewing from different 
azimuths.  Set background and exaggeration values to better represent ground deformation areas 
depicted by the radar imagery. 
 
Step 6: Create and animation “fly through” of the study area using the Animation tools.  You 
might want to start with an entire view of the earth and then zoom in to the U.S. – Wyoming – 
Yellowstone – and then down to the study area resolution where you begin a 3D tour of the Park.       
 
 
 

 
    
 
 
 
  


